summaryrefslogtreecommitdiffstats
path: root/abs/core/apr/ship_find_apr.m4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/apr/ship_find_apr.m4.patch')
-rw-r--r--abs/core/apr/ship_find_apr.m4.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/apr/ship_find_apr.m4.patch b/abs/core/apr/ship_find_apr.m4.patch
new file mode 100644
index 0000000..0393970
--- /dev/null
+++ b/abs/core/apr/ship_find_apr.m4.patch
@@ -0,0 +1,25 @@
+From: Tollef Fog Heen <tfheen@err.no>
+Subject: Install a set of random build files too
+
+---
+ Makefile.in | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+--- apr.orig/Makefile.in
++++ apr/Makefile.in
+@@ -92,6 +92,15 @@ install: $(TARGETS)
+ done
+ $(INSTALL_DATA) build/apr_rules.out $(DESTDIR)$(installbuilddir)/apr_rules.mk
+ $(INSTALL) -m 755 apr-config.out $(DESTDIR)$(bindir)/$(APR_CONFIG)
++
++ if [ ! -d $(DESTDIR)$(installbuilddir) ]; then \
++ $(top_srcdir)/build/mkdir.sh $(DESTDIR)$(installbuilddir); \
++ fi
++ for file in find_apr.m4 apr_common.m4 install.sh gen-build.py get-version.sh ; do \
++ $(LIBTOOL) --mode=install cp $(top_srcdir)/build/$$file \
++ $(DESTDIR)$(installbuilddir)/$$file ; \
++ done
++
+ @if [ $(INSTALL_SUBDIRS) != "none" ]; then \
+ for i in $(INSTALL_SUBDIRS); do \
+ ( cd $$i ; $(MAKE) DESTDIR=$(DESTDIR) install ); \