summaryrefslogtreecommitdiffstats
path: root/abs/core/aspell/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aspell/PKGBUILD')
-rw-r--r--abs/core/aspell/PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/abs/core/aspell/PKGBUILD b/abs/core/aspell/PKGBUILD
index 50c9264..2cdaf6d 100644
--- a/abs/core/aspell/PKGBUILD
+++ b/abs/core/aspell/PKGBUILD
@@ -8,20 +8,21 @@
pkgname=aspell
pkgver=0.60.6.1
_pkgmajorver=0.60
-pkgrel=2
+pkgrel=5
pkgdesc="A spell checker designed to eventually replace Ispell"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://aspell.net/"
license=('LGPL')
depends=('gcc-libs' 'ncurses')
optdepends=('perl: to import old dictionaries')
-install=aspell.install
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('e66a9c9af6a60dc46134fdacf6ce97d7')
-sha1sums=('ff1190db8de279f950c242c6f4c5d5cdc2cbdc49')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ gcc7fixes.patch)
+sha1sums=('ff1190db8de279f950c242c6f4c5d5cdc2cbdc49'
+ 'df5364a8472154452f4e1fe9db0891df457949e0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < $srcdir/gcc7fixes.patch
./configure --prefix=/usr --sysconfdir=/etc
make
}