summaryrefslogtreecommitdiffstats
path: root/abs/core/aspell/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aspell/PKGBUILD')
-rw-r--r--abs/core/aspell/PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/abs/core/aspell/PKGBUILD b/abs/core/aspell/PKGBUILD
index 0b8a590..8d584b9 100644
--- a/abs/core/aspell/PKGBUILD
+++ b/abs/core/aspell/PKGBUILD
@@ -1,24 +1,31 @@
-# $Id: PKGBUILD 521 2008-04-20 13:00:37Z andyrtr $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 19099 2008-11-14 21:50:10Z thayer $
# Contributor: Jochem Kossen <j.kossen@home.nl>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+
pkgname=aspell
pkgver=0.60.6
_pkgmajorver=0.60
-pkgrel=1
-pkgdesc="A Free and Open Source spell checker designed to eventually replace Ispell"
-arch=(i686 x86_64)
+pkgrel=4
+pkgdesc="A spell checker designed to eventually replace Ispell"
+url="http://aspell.net/"
+arch=('i686' 'x86_64')
license=('LGPL')
-depends=('gcc-libs' 'ncurses')
+depends=('gcc-libs' 'ncurses>=5.6-7')
+optdepends=('perl: to import old dictionaries')
options=(!libtool)
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
install=aspell.install
-url="http://aspell.net/"
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
md5sums=('bc80f0198773d5c05086522be67334eb')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install
- ln -s ${pkgname}-${_pkgmajorver} ${startdir}/pkg/usr/lib/${pkgname}
+ make DESTDIR=${pkgdir} install || return 1
+ ln -s ${pkgname}-${_pkgmajorver} ${pkgdir}/usr/lib/${pkgname} || return 1
+
+ # cleanup info files
+ rm ${pkgdir}/usr/share/info/dir || return 1
+ gzip ${pkgdir}/usr/share/info/* || return 1
}