summaryrefslogtreecommitdiffstats
path: root/abs/core/aufs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aufs/PKGBUILD')
-rw-r--r--abs/core/aufs/PKGBUILD44
1 files changed, 29 insertions, 15 deletions
diff --git a/abs/core/aufs/PKGBUILD b/abs/core/aufs/PKGBUILD
index 57b6e24..3f1e1d0 100644
--- a/abs/core/aufs/PKGBUILD
+++ b/abs/core/aufs/PKGBUILD
@@ -1,36 +1,49 @@
-# $Id: PKGBUILD 5885 2008-07-21 19:28:11Z thomas $
+# $Id: PKGBUILD 22431 2008-12-26 20:13:34Z tpowa $
# Contributor: Paul Mattal <paul@mattal.com>
# Maintainer: Paul Mattal <pjmattal@elys.com>
pkgname=aufs
-pkgver=20080527
+pkgver=20081226
pkgrel=2
-_kernver='2.6.26-ARCH'
+_kernver='2.6.28-LinHES'
pkgdesc="Another Unionfs Implementation that supports NFS branches"
arch=('i686' 'x86_64')
url="http://aufs.sourceforge.net/"
license=('GPL2')
-depends=('kernel26>=2.6.26-1' 'kernel26<=2.6.27' 'glibc' 'aufs-utils')
+depends=('kernel26>=2.6.28' 'kernel26<2.6.29' 'glibc' 'aufs-utils=20081226')
install=$pkgname.install
-source=(ftp://ftp.archlinux.org/other/aufs/$pkgname-$pkgver.tar.gz)
+source=(ftp://ftp.archlinux.org/other/aufs/$pkgname-$pkgver.tar.bz2)
options=(!libtool !makeflags)
-md5sums=('4378221aa5763d1f4408a0bbb0e80f0a')
build() {
- cd $startdir/src/$pkgname || return 1
+ cd $srcdir/$pkgname || return 1
- # use splice functions exported by unionfs kernel patch
- # - important for loopback fs mounts
- sed s'|#if.*KERNEL_VERSION(2, 6, 26).*|#if 0|' -i fs/aufs25/vfsub.h \
- || return 1
+ # Fix TMPFS_MAGIC error
+ sed 's|-le 26|-le 27|g' -i fs/aufs25/Makefile || return 1
+
+ # use splice functions exported by unionfs kernel patch'
+ # - important for loopback fs mounts
sed -i 's|CONFIG_AUFS_SPLICE_PATCH =|CONFIG_AUFS_SPLICE_PATCH = y|' \
- local.mk || return 1
+ local.mk || return 1
+
+ # this fixes the unionfs patch from hanging aufs
+ sed -i 's|CONFIG_AUFS_UNIONFS23_PATCH =|CONFIG_AUFS_UNIONFS23_PATCH = y|' \
+ local.mk || return 1
+
+ sed -i 's|CONFIG_AUFS_WORKAROUND_FUSE =|CONFIG_AUFS_WORKAROUND_FUSE = y|' \
+ local.mk || return 1
- # patch for spin_lock conflict with the new unionfs patch
- sed s'|#if.*KERNEL_VERSION(2, 6, 26).*|#if 0|' -i fs/aufs25/cpup.c \
- || return 1
+ sed -i 's|CONFIG_AUFS_BRANCH_MAX_127 = y|CONFIG_AUFS_BRANCH_MAX_127 =|' \
+ local.mk || return 1
+
+ sed -i 's|CONFIG_AUFS_BRANCH_MAX_1023 =|CONFIG_AUFS_BRANCH_MAX_1023 = y|' \
+ local.mk || return 1
+ # ???
sed -i 's|.*CONFIG_AUFS_SHWH =.*|CONFIG_AUFS_SHWH = y|' \
local.mk || return 1
+ # disable debug, broken in 2.6.28!
+ sed -i 's|CONFIG_AUFS_DEBUG = y|CONFIG_AUFS_DEBUG = |' \
+ local.mk || return 1
# configure for NFS by:
# 1) configure local.mk to use FILP and LHASH
@@ -55,3 +68,4 @@ build() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('e855ed9edc16953028f22cae393690de')