summaryrefslogtreecommitdiffstats
path: root/abs/core/autoconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/autoconf/PKGBUILD')
-rw-r--r--abs/core/autoconf/PKGBUILD37
1 files changed, 27 insertions, 10 deletions
diff --git a/abs/core/autoconf/PKGBUILD b/abs/core/autoconf/PKGBUILD
index 1ac8ed6..6f3e18c 100644
--- a/abs/core/autoconf/PKGBUILD
+++ b/abs/core/autoconf/PKGBUILD
@@ -1,25 +1,42 @@
-# $Id: PKGBUILD 12545 2008-09-15 12:33:36Z andyrtr $
-# Maintainer: Andreas Radke <adyrtr@archlinux.org>
+# $Id: PKGBUILD 157321 2012-04-27 00:50:14Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname=autoconf
-pkgver=2.66
+pkgver=2.69
pkgrel=1
pkgdesc="A GNU tool for automatically configuring source code"
-arch=(i686 x86_64)
-license=('GPL2' 'GPL3')
+arch=('any')
+license=('GPL2' 'GPL3' 'custom')
url="http://www.gnu.org/software/autoconf"
groups=('base-devel')
depends=('awk' 'm4' 'diffutils' 'bash')
+# for test-suite
+#makedepends=('gcc-fortran' 'erlang')
install=autoconf.install
-source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
+md5sums=('50f97f4159805e374639a73e2636f22e'
+ '2941e2fe687e05b3431eac6b714053bc')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- rm -f ${pkgdir}/usr/share/info/dir
+ make
+}
+
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+
+ # license exception
+ install -Dm644 COPYING.EXCEPTION \
+ $pkgdir/usr/share/licenses/autoconf/COPYING.EXCEPTION
+
# conflict with bintuils
rm -f ${pkgdir}/usr/share/info/standards.info
}
-md5sums=('fb00d77cbc468994c55919298af1ff02')