summaryrefslogtreecommitdiffstats
path: root/abs/core/avahi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/avahi/PKGBUILD')
-rw-r--r--abs/core/avahi/PKGBUILD104
1 files changed, 50 insertions, 54 deletions
diff --git a/abs/core/avahi/PKGBUILD b/abs/core/avahi/PKGBUILD
index d98069b..5aa2247 100644
--- a/abs/core/avahi/PKGBUILD
+++ b/abs/core/avahi/PKGBUILD
@@ -1,16 +1,19 @@
# $Id$
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgname=avahi
-pkgver=0.6.31
-pkgrel=14
-pkgdesc='Multicast/unicast DNS-SD framework'
-url='http://www.avahi.org/'
-license=('LGPL')
-arch=('i686' 'x86_64')
-options=('!emptydirs')
-depends=('expat' 'libdaemon' 'glib2' 'libcap' 'gdbm' 'dbus')
+pkgver=0.6.32
+pkgrel=2
+_commit=4f334990f692ce08ab4ea2eece695f1592f535b2
+pkgdesc='Service Discovery for Linux using mDNS/DNS-SD -- compatible with Bonjour'
+url='https://github.com/lathiat/avahi'
+license=(LGPL)
+arch=(i686 x86_64)
+depends=(expat libdaemon glib2 libcap gdbm dbus)
+makedepends=(git qt4 pygtk mono intltool python2-dbus gtk-sharp-2 gobject-introspection gtk3
+ xmltoman)
optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
'gtk2: gtk2 bindings'
'qt4: qt4 bindings'
@@ -19,62 +22,55 @@ optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
'mono: mono bindings'
'python2-dbus: avahi-discover'
'nss-mdns: NSS support for mDNS')
-makedepends=('qt4' 'pygtk' 'mono' 'intltool' 'python2-dbus'
- 'gtk-sharp-2' 'gobject-introspection' 'gtk3' 'xmltoman')
-backup=('etc/avahi/hosts'
- 'etc/avahi/avahi-daemon.conf'
- 'etc/avahi/services/ssh.service'
- 'etc/avahi/services/sftp-ssh.service'
- 'usr/lib/avahi/service-types.db'
- 'usr/share/avahi/service-types')
-source=("http://www.avahi.org/download/avahi-${pkgver}.tar.gz")
-sha1sums=('7e05bd78572c9088b03b1207a0ad5aba38490684')
+install=avahi.install
+backup=(etc/avahi/{hosts,avahi-daemon.conf}
+ usr/lib/avahi/service-types.db usr/share/avahi/service-types)
+source=("git+$url#commit=$_commit")
+sha256sums=('SKIP')
-conflicts=('howl' 'mdnsresponder')
-provides=('howl' 'mdnsresponder')
-
-install=install
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- sed '/^Libs:/s:$: -ldbus-1:' -i avahi-client.pc.in
- sed 's:netdev:network:g' -i avahi-daemon/avahi-dbus.conf
- sed 's:/sbin/resolvconf:/usr/sbin/resolvconf:g' -i */*.action
- sed 's:-DG[^ ]*_DISABLE_DEPRECATED=1::g' -i avahi-ui/Makefile.*
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- export MOC_QT4=/usr/bin/moc-qt4
- export PYTHON=/usr/bin/python2
+ cd $pkgname
+ export MOC_QT4=/usr/bin/moc-qt4 PYTHON=/usr/bin/python2
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --disable-monodoc \
+ --disable-qt3 \
+ --enable-compat-libdns_sd \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --with-autoipd-user=avahi \
+ --with-autoipd-group=avahi \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --sbindir=/usr/bin \
- --disable-monodoc \
- --disable-qt3 \
- --enable-compat-libdns_sd \
- --enable-compat-howl \
- --with-distro=archlinux \
- --with-avahi-priv-access-group=network \
- --with-autoipd-user=avahi \
- --with-autoipd-group=avahi \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ cp -a avahi-python/avahi avahi-python/avahi3
- make
+ make
+ make -C avahi-python/avahi3 PYTHON=/usr/bin/python2
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- rm -fr "${pkgdir}"/etc/rc.d
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C avahi-python/avahi3 install \
+ PYTHON=/usr/bin/python2 pythondir=/usr/lib/python2.7/site-packages
+
+ # mdnsresponder compat
+ ln -s avahi-compat-libdns_sd/dns_sd.h "$pkgdir/usr/include/dns_sd.h"
- # howl and mdnsresponder compatability
- cd "${pkgdir}"/usr/include; ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h; ln -s avahi-compat-howl howl
- cd "${pkgdir}"/usr/lib/pkgconfig; ln -s avahi-compat-howl.pc howl.pc
+ # move example services https://bugs.archlinux.org/task/47822
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir"/etc/avahi/services/{,sftp-}ssh.service \
+ "$pkgdir/usr/share/doc/$pkgname/"
- # see FS#42638
- ln avahi-daemon.service -s "${pkgdir}"/usr/lib/systemd/system/dbus-org.freedesktop.Avahi.service
+ rmdir "$pkgdir"/var{/run,}
}