summaryrefslogtreecommitdiffstats
path: root/abs/core/bc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/bc/PKGBUILD')
-rw-r--r--abs/core/bc/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/bc/PKGBUILD b/abs/core/bc/PKGBUILD
new file mode 100644
index 0000000..88a85df
--- /dev/null
+++ b/abs/core/bc/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: dorphell <dorphell@archlinux.org>
+
+pkgname=bc
+pkgver=1.06
+pkgrel=4
+pkgdesc="An arbitrary precision calculator language"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('readline')
+replaces=(bc-readline)
+conflicts=(bc-readline)
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ build-fix.patch)
+md5sums=('d44b5dddebd8a7a7309aea6c36fda117' 'fc7ecbd9e55ef04c6d3a495692626116')
+
+build() {
+ CFLAGS="$CFLAGS -O3"
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ patch -Np1 -i ${startdir}/src/build-fix.patch || return 1
+ ./configure --prefix=/usr --with-readline
+ make LEX="flex -I" || return 1
+ make DESTDIR=${startdir}/pkg install
+}