summaryrefslogtreecommitdiffstats
path: root/abs/core/binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/binutils/PKGBUILD')
-rw-r--r--abs/core/binutils/PKGBUILD82
1 files changed, 43 insertions, 39 deletions
diff --git a/abs/core/binutils/PKGBUILD b/abs/core/binutils/PKGBUILD
index 4c6e5a9..a4d2839 100644
--- a/abs/core/binutils/PKGBUILD
+++ b/abs/core/binutils/PKGBUILD
@@ -1,56 +1,63 @@
-# $Id$
+# $Id: PKGBUILD 171025 2012-11-15 12:26:41Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
pkgname=binutils
-pkgver=2.21.1
+pkgver=2.23.1
pkgrel=1
-_date=20110627
pkgdesc="A set of programs to assemble and manipulate binary and object files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/binutils/"
license=('GPL')
-groups=('base')
-depends=('glibc>=2.14' 'zlib')
-checkdepends=('dejagnu')
+groups=('base-devel')
+depends=('glibc>=2.16' 'zlib')
+checkdepends=('dejagnu' 'bc')
options=('!libtool' '!distcc' '!ccache')
install=binutils.install
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}_${_date}.tar.bz2)
-md5sums=('2face559e80d649ba148e42bb2d1fb0f')
-
-mksource() {
- mkdir ${pkgname}-${_date}
- cd ${pkgname}-${_date}
- export _TAG=binutils-2_21-branch
- export 'CVSROOT=:pserver:anoncvs@sourceware.org:/cvs/src'
- cvs -z9 co -r $_TAG binutils || return 1
- mv src binutils
- tar -cvjf ../binutils-${pkgver}_${_date}.tar.bz2 binutils/*
-}
+source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig})
+md5sums=('33adb18c3048d057ac58d07a3f1adb38'
+ '1869b37216e7d7eff7e335a69e0882fd')
build() {
cd ${srcdir}
mkdir binutils-build && cd binutils-build
- [[ $CARCH == "x86_64" ]] && CONFIGFLAG="--enable-64-bit-bfd --disable-multilib"
-
- ${srcdir}/binutils/configure --prefix=/usr \
+ ${srcdir}/binutils-${pkgver}/configure --prefix=/usr \
+ --with-lib-path=/usr/lib:/usr/local/lib \
+ --with-bugurl=https://bugs.archlinux.org/ \
--enable-ld=default --enable-gold \
- --enable-plugins --enable-threads \
- --enable-shared $CONFIGFLAG
+ --enable-plugins --enable-threads --enable-shared \
+ --disable-werror --disable-multilib
# check the host environment and makes sure all the necessary tools are available
make configure-host
make tooldir=${pkgdir}/usr
+
+ # Rebuild libiberty.a with -fPIC
+ cp -a libiberty libiberty-pic
+ make -C libiberty-pic clean
+ make CFLAGS="$CFLAGS -fPIC" -C libiberty-pic
+
+ # Rebuild libbfd.a with -fPIC
+ # hidden visability prevent 3rd party shared libraries exporting bfd non-stable API
+ cp -a bfd bfd-pic
+ make -C bfd-pic clean
+ make CFLAGS="$CFLAGS -fPIC -fvisibility=hidden" -C bfd-pic
+
+ # Rebuild libopcodes.a with -fPIC
+ cp -a opcodes opcodes-pic
+ make -C opcodes-pic clean
+ make CFLAGS="$CFLAGS -fPIC" -C opcodes-pic
}
check() {
cd ${srcdir}/binutils-build
-
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
# do not abort on errors - manually check log files
- make -k -j1 check || true
+ make LDFLAGS="" -k check || true
}
package() {
@@ -58,26 +65,23 @@ package() {
make prefix=${pkgdir}/usr tooldir=${pkgdir}/usr install
# Add some useful headers
- install -m644 ${srcdir}/binutils/include/libiberty.h ${pkgdir}/usr/include
- install -m644 ${srcdir}/binutils/include/demangle.h ${pkgdir}/usr/include
-
- # Rebuild libiberty.a with -fPIC
- make -C libiberty clean
- make CFLAGS="$CFLAGS -fPIC" -C libiberty
- install -m644 libiberty/libiberty.a ${pkgdir}/usr/lib
+ install -m644 ${srcdir}/binutils-${pkgver}/include/libiberty.h ${pkgdir}/usr/include
+ install -m644 ${srcdir}/binutils-${pkgver}/include/demangle.h ${pkgdir}/usr/include
- # Rebuild libbfd.a with -fPIC
- make -C bfd clean
- # hidden visability prevent 3rd party shared libraries exporting bfd non-stable API
- make CFLAGS="$CFLAGS -fPIC -fvisibility=hidden" -C bfd
- install -m644 bfd/libbfd.a ${pkgdir}/usr/lib
+ # install libraries rebuilt with -fPIC
+ install -m644 libiberty-pic/libiberty.a ${pkgdir}/usr/lib
+ install -m644 bfd-pic/libbfd.a ${pkgdir}/usr/lib
+ install -m644 opcodes/libopcodes.a ${pkgdir}/usr/lib
# Remove Windows/Novell specific man pages
- rm -f ${pkgdir}/usr/share/man/man1/{dlltool,nlmconv,windres,windmc}*
+ rm ${pkgdir}/usr/share/man/man1/{dlltool,nlmconv,windres,windmc}*
+
+ # why are these distributed with binutils?
+ rm ${pkgdir}/usr/share/info/{configure,standards}.info
# Remove these symlinks, they are not ABI stable.
# Programs should compile static to the .a file.
- rm -f ${pkgdir}/usr/lib/lib{bfd,opcodes}.so
+ rm ${pkgdir}/usr/lib/lib{bfd,opcodes}.so
echo "INPUT ( /usr/lib/libbfd.a -liberty -lz )" >${pkgdir}/usr/lib/libbfd.so
echo "INPUT ( /usr/lib/libopcodes.a -lbfd )" >${pkgdir}/usr/lib/libopcodes.so
}