summaryrefslogtreecommitdiffstats
path: root/abs/core/coreutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/coreutils/PKGBUILD')
-rw-r--r--abs/core/coreutils/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/abs/core/coreutils/PKGBUILD b/abs/core/coreutils/PKGBUILD
index 6762512..44154a2 100644
--- a/abs/core/coreutils/PKGBUILD
+++ b/abs/core/coreutils/PKGBUILD
@@ -5,27 +5,30 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=coreutils
-pkgver=8.24
+pkgver=8.29
pkgrel=1
pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL3')
-url='http://www.gnu.org/software/coreutils'
+url='https://www.gnu.org/software/coreutils/'
groups=('base')
depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
-install=$pkgname.install
-source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
-md5sums=('40efdbce865d2458d8da0a9dcee7c16c'
+md5sums=('960cfe75a42c9907c71439f8eb436303'
'SKIP')
prepare() {
- local _p
- for _p in *.patch; do
- [[ -e $_p ]] || continue
- msg2 "Applying $_p"
- patch -p1 -d $pkgname-$pkgver < "$_p"
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
done
+ :
}
build() {
@@ -41,7 +44,7 @@ build() {
check() {
cd $pkgname-$pkgver
- make check
+ #make check
}
package() {