summaryrefslogtreecommitdiffstats
path: root/abs/core/coreutils/coreutils-pam.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/coreutils/coreutils-pam.patch')
-rw-r--r--abs/core/coreutils/coreutils-pam.patch26
1 files changed, 18 insertions, 8 deletions
diff --git a/abs/core/coreutils/coreutils-pam.patch b/abs/core/coreutils/coreutils-pam.patch
index 8593ecc..7171522 100644
--- a/abs/core/coreutils/coreutils-pam.patch
+++ b/abs/core/coreutils/coreutils-pam.patch
@@ -49,11 +49,11 @@
#define DEFAULT_USER "root"
+#ifndef USE_PAM
- char *crypt ();
+ char *crypt (char const *key, char const *salt);
+#endif
- char *getusershell ();
- void endusershell ();
- void setusershell ();
+ char *getusershell (void);
+ void endusershell (void);
+ void setusershell (void);
extern char **environ;
@@ -66,8 +66,8 @@
ATTRIBUTE_NORETURN;
+#endif
- /* The name this program was run with. */
- char *program_name;
+ /* If true, pass the `-f' option to the subshell. */
+ static bool fast_startup;
@@ -225,7 +251,26 @@
}
#endif
@@ -361,6 +361,15 @@
The program accepts the following options. Also see @ref{Common options}.
+@@ -12815,6 +12815,8 @@
+ @env{PATH} to a compiled-in default value. Change to @var{user}'s home
+ directory. Prepend @samp{-} to the shell's name, intended to make it
+ read its login startup file(s).
++Additionaly @env{DISPLAY} and @env{XAUTHORITY} environment variables
++are preserved as well for PAM functionality.
+
+ @item -m
+ @itemx -p
@@ -13477,33 +13480,6 @@
the exit status of the subshell otherwise
@end display
@@ -392,8 +401,8 @@
-might find this idea strange at first.
-
-
- @node Process control
- @chapter Process control
+ @node timeout invocation
+ @section @command{timeout}: Run a command with a time limit
--- coreutils-6.7/configure.ac.pam 2006-12-07 21:30:24.000000000 +0000
+++ coreutils-6.7/configure.ac 2007-01-09 17:18:04.000000000 +0000
@@ -411,3 +420,4 @@
AC_FUNC_FORK
optional_bin_progs=
+