summaryrefslogtreecommitdiffstats
path: root/abs/core/cython/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/cython/PKGBUILD')
-rw-r--r--abs/core/cython/PKGBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/abs/core/cython/PKGBUILD b/abs/core/cython/PKGBUILD
deleted file mode 100644
index 1952091..0000000
--- a/abs/core/cython/PKGBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# $Id$
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: Igor Scabini <furester @ gmail.com>
-
-pkgname=('cython2')
-pkgbase=cython
-pkgver=0.24
-pkgrel=1
-pkgdesc="C-Extensions for Python "
-arch=(i686 x86_64)
-url="http://www.cython.org"
-license=('APACHE')
-makedepends=('python2-setuptools')
-source=("http://cython.org/release/Cython-$pkgver.tar.gz")
-md5sums=('14fbc970f4a856845e633cbc09e61048')
-
-package_cython() {
- depends=('python' 'python-setuptools')
-
- cd $srcdir/Cython-$pkgver
- python setup.py install --root=$pkgdir
-
- sed -i 's|#!.*python|#!/usr/bin/python3|' $pkgdir/usr/bin/*
-}
-
-package_cython2() {
- depends=('python2' 'python2-setuptools')
-
- cd $srcdir/Cython-$pkgver
- python2 setup.py install --root=$pkgdir
-
- mv $pkgdir/usr/bin/cygdb $pkgdir/usr/bin/cygdb2
- mv $pkgdir/usr/bin/cython $pkgdir/usr/bin/cython2
- mv $pkgdir/usr/bin/cythonize $pkgdir/usr/bin/cythonize2
-}