summaryrefslogtreecommitdiffstats
path: root/abs/core/dbus-core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/dbus-core')
-rw-r--r--abs/core/dbus-core/PKGBUILD26
-rw-r--r--abs/core/dbus-core/dbus2
-rw-r--r--abs/core/dbus-core/dbus.install19
3 files changed, 25 insertions, 22 deletions
diff --git a/abs/core/dbus-core/PKGBUILD b/abs/core/dbus-core/PKGBUILD
index 7a1bc6e..b57829f 100644
--- a/abs/core/dbus-core/PKGBUILD
+++ b/abs/core/dbus-core/PKGBUILD
@@ -1,36 +1,36 @@
-# $Id: PKGBUILD 19084 2008-11-14 21:36:59Z jgc $
+# $Id: PKGBUILD 73272 2010-03-24 11:36:47Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Link Dupont <link@subpop.net>
#
pkgname=dbus-core
-pkgver=1.2.4
+pkgver=1.2.24
pkgrel=1
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
arch=(i686 x86_64)
license=('GPL' 'custom')
-depends=('expat>=2.0')
+depends=('expat>=2.0.1' 'coreutils' 'filesystem')
conflicts=('dbus<1.2.3-2')
options=(!libtool)
install=dbus.install
source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
- dbus)
-md5sums=('2e643910a09f44b000a0d76038637999'
- 'f3fd196cc278bd7b45a4ca01fb8f7894')
+ dbus)
+md5sums=('565346cecd9cfecf1463540c6086cc2c'
+ '08f93dd19cffd1b45ab05c1fd4efb560')
build() {
cd "${srcdir}/dbus-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
- --with-system-pid-file=/var/run/dbus.pid \
- --enable-inotify --disable-dnotify \
- --disable-verbose-mode --disable-static \
- --disable-tests --disable-asserts --without-x || return 1
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --enable-inotify --disable-dnotify \
+ --disable-verbose-mode --disable-static \
+ --disable-tests --disable-asserts --without-x || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
- rm -f ${pkgdir}/usr/bin/dbus-launch
- rm -f ${pkgdir}/usr/share/man/man1/dbus-launch.1
+ rm -f "${pkgdir}/usr/bin/dbus-launch"
+ rm -f "${pkgdir}/usr/share/man/man1/dbus-launch.1"
chown 81:81 "${pkgdir}/var/run/dbus" || return 1
diff --git a/abs/core/dbus-core/dbus b/abs/core/dbus-core/dbus
index cd26db8..66b84ca 100644
--- a/abs/core/dbus-core/dbus
+++ b/abs/core/dbus-core/dbus
@@ -24,7 +24,7 @@ case "$1" in
;;
stop)
stat_busy "Stopping D-BUS system messagebus"
- [ -f /var/run/dbus.pid ] && kill `cat /var/run/dbus.pid`
+ [ -f /var/run/dbus.pid ] && kill `cat /var/run/dbus.pid` >/dev/null 2>&1
if [ $? -gt 0 ]; then
stat_fail
else
diff --git a/abs/core/dbus-core/dbus.install b/abs/core/dbus-core/dbus.install
index 85dd9a7..44f4475 100644
--- a/abs/core/dbus-core/dbus.install
+++ b/abs/core/dbus-core/dbus.install
@@ -5,17 +5,20 @@ post_install() {
dbus-uuidgen --ensure
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- post_install $1
+ post_install
#Make sure new rc script can shutdown running dbus
- [ -f var/run/dbus/pid ] && mv var/run/dbus/pid var/run/dbus.pid
+ if [ -f var/run/dbus/pid ]; then
+ mv var/run/dbus/pid var/run/dbus.pid
+ fi
}
-# arg 1: the old package version
-pre_remove() {
- usr/sbin/userdel dbus &>/dev/null
- usr/sbin/groupdel dbus &>/dev/null
+post_remove() {
+ if getent passwd dbus >/dev/null; then
+ usr/sbin/userdel dbus
+ fi
+ if getent group dbus >/dev/null; then
+ usr/sbin/groupdel dbus
+ fi
}