summaryrefslogtreecommitdiffstats
path: root/abs/core/ddcxinfo
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ddcxinfo')
-rw-r--r--abs/core/ddcxinfo/PKGBUILD25
-rw-r--r--abs/core/ddcxinfo/ddcxinfo-kanotix_0.6.19.tar.gzbin0 -> 39882 bytes
-rw-r--r--abs/core/ddcxinfo/lrmi.patch18
3 files changed, 43 insertions, 0 deletions
diff --git a/abs/core/ddcxinfo/PKGBUILD b/abs/core/ddcxinfo/PKGBUILD
new file mode 100644
index 0000000..b358c0c
--- /dev/null
+++ b/abs/core/ddcxinfo/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=ddcxinfo
+pkgver=0.6.19
+pkgrel=3
+pkgdesc="DDC readout using the VESA BIOS extension"
+url="http://www.t2-project.org/packages/ddcxinfo.html"
+license="GPL"
+depends=(x-server)
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+arch=('i686')
+install=
+source=(http://www.kanotix.com/files/debian/pool/main/d/ddcxinfo-kanotix/$pkgname-kanotix_$pkgver.tar.gz
+ lrmi.patch)
+
+
+build() {
+ cd $startdir/src/$pkgname-kanotix-$pkgver
+ mkdir -p $startdir/pkg/usr/sbin
+ patch -p1 < $startdir/src/lrmi.patch
+ make DESTDIR=$startdir/pkg install
+ cp svgamodes $startdir/pkg/usr/sbin/
+ chmod +s $startdir/pkg/usr/sbin/ddcprobe
+}
diff --git a/abs/core/ddcxinfo/ddcxinfo-kanotix_0.6.19.tar.gz b/abs/core/ddcxinfo/ddcxinfo-kanotix_0.6.19.tar.gz
new file mode 100644
index 0000000..fbbb329
--- /dev/null
+++ b/abs/core/ddcxinfo/ddcxinfo-kanotix_0.6.19.tar.gz
Binary files differ
diff --git a/abs/core/ddcxinfo/lrmi.patch b/abs/core/ddcxinfo/lrmi.patch
new file mode 100644
index 0000000..ca735fa
--- /dev/null
+++ b/abs/core/ddcxinfo/lrmi.patch
@@ -0,0 +1,18 @@
+Common subdirectories: ddcxinfo-kanotix-0.6.19-orig/debian and ddcxinfo-kanotix-0.6.19/debian
+diff -u ddcxinfo-kanotix-0.6.19-orig/lrmi.c ddcxinfo-kanotix-0.6.19/lrmi.c
+--- ddcxinfo-kanotix-0.6.19-orig/lrmi.c 2009-07-25 06:15:09.000000000 +0000
++++ ddcxinfo-kanotix-0.6.19/lrmi.c 2009-07-25 06:17:22.000000000 +0000
+@@ -170,6 +170,13 @@
+ }
+ }
+
++#ifndef TF_MASK
++#define TF_MASK X86_EFLAGS_TF
++#define IF_MASK X86_EFLAGS_IF
++#define IOPL_MASK X86_EFLAGS_IOPL
++#define VIF_MASK X86_EFLAGS_VIF
++#define VIP_MASK X86_EFLAGS_VIP
++#endif
+
+ #define DEFAULT_VM86_FLAGS (IF_MASK | IOPL_MASK)
+ #define DEFAULT_STACK_SIZE 0x1000