summaryrefslogtreecommitdiffstats
path: root/abs/core/elfutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/elfutils/PKGBUILD')
-rw-r--r--abs/core/elfutils/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/elfutils/PKGBUILD b/abs/core/elfutils/PKGBUILD
new file mode 100644
index 0000000..5ecdcde
--- /dev/null
+++ b/abs/core/elfutils/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 87360 2010-08-13 03:21:31Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Andrej Gelenberg <andrej.gelenberg@udo.edu>
+
+pkgname=elfutils
+pkgver=0.148
+pkgrel=1
+pkgdesc="Collection of libraries and utilities for working with ELF object files and DWARF debugging information"
+arch=('i686' 'x86_64')
+url="https://fedorahosted.org/elfutils/"
+license=('GPL2')
+depends=('glibc')
+#optdepends=('zlib' 'xz' 'bzip2')
+provides=('libelf')
+replaces=('libelf')
+conflicts=('libelf')
+source=(https://fedorahosted.org/releases/e/l/elfutils/${pkgver}/elfutils-${pkgver}.tar.bz2)
+md5sums=('a0bed1130135f17ad27533b0034dba8d')
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --program-prefix="eu-"
+ make
+ make check
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}