summaryrefslogtreecommitdiffstats
path: root/abs/core/fbsplash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fbsplash/PKGBUILD')
-rw-r--r--abs/core/fbsplash/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/abs/core/fbsplash/PKGBUILD b/abs/core/fbsplash/PKGBUILD
new file mode 100644
index 0000000..736da1f
--- /dev/null
+++ b/abs/core/fbsplash/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Greg Helton <gt@fallendusk.org>
+
+pkgname=fbsplash
+pkgver=1.5.4.3
+pkgrel=15
+pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
+arch=('i686' 'x86_64')
+url="http://fbsplash.berlios.de"
+license=('GPL')
+backup=('etc/conf.d/fbsplash.conf' 'etc/conf.d/fbsplash.bootsteps')
+makedepends=('klibc')
+depends=('initscripts' 'miscsplashutils' 'libjpeg' 'libpng' 'freetype2-static' 'gpm' 'libmng' 'which' 'linhes-splash')
+conflicts=('bootsplash' 'gensplash')
+install=fbsplash.install
+source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2 \
+ http://code.thewrecker.net/files/darch.tar.bz2 \
+ fbsplash.inithooks \
+ splash-functions-arch.sh \
+ fbsplash.conf \
+ fbsplash.initcpio_install \
+ fbsplash.daemon fbsplash.bootsteps)
+build() {
+ cd ${startdir}/src/splashutils-${pkgver}
+
+ # Configure, make, and install
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
+ make || return 1
+ cp -f ${startdir}/splash-functions.sh ${startdir}/src/splashutils-1.5.4.3/scripts/splash-functions.sh
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ # Create directories
+ mkdir -p ${startdir}/pkg/lib/splash/cache
+ mkdir -p ${startdir}/pkg/etc/splash
+ mkdir -p ${startdir}/pkg/etc/rc.d/functions.d
+
+ # Install scripts
+ install -D -m644 ${startdir}/src/fbsplash.initcpio_install ${startdir}/pkg/lib/initcpio/install/fbsplash
+ install -D -m644 ${startdir}/src/fbsplash.conf ${startdir}/pkg/etc/conf.d/fbsplash.conf
+ install -D -m744 ${startdir}/src/fbsplash.daemon ${startdir}/pkg/etc/rc.d/fbsplash
+ install -D -m744 ${startdir}/src/splash-functions-arch.sh ${startdir}/pkg/sbin/splash-functions-arch.sh
+ install -D -m755 $startdir/src/fbsplash.bootsteps ${startdir}/pkg/etc/conf.d/fbsplash.bootsteps
+
+ # install darch fbsplash theme
+ cp -r ${startdir}/src/darch ${startdir}/pkg/etc/splash/darch
+
+ # install initscripts hooks
+ install -D -m744 ${startdir}/src/fbsplash.inithooks ${startdir}/pkg/etc/rc.d/functions.d/fbsplash.sh
+
+}
+md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
+ '4ea33e99330abf4a9a468ac8c0ba48ca'
+ '33b3c7c2050670db0e8b2efd9e088ed9'
+ '8ffb29400a2518b16f3dbca653855268'
+ '82ef6f37c2795db1b4fec0e6f8443c66'
+ '21380586a5dafbf7045886ea4374ab65'
+ 'bb5154529e4b5fbc701cf4540c15a61a')