summaryrefslogtreecommitdiffstats
path: root/abs/core/fbsplash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fbsplash/PKGBUILD')
-rw-r--r--abs/core/fbsplash/PKGBUILD103
1 files changed, 59 insertions, 44 deletions
diff --git a/abs/core/fbsplash/PKGBUILD b/abs/core/fbsplash/PKGBUILD
index 736da1f..dcec71a 100644
--- a/abs/core/fbsplash/PKGBUILD
+++ b/abs/core/fbsplash/PKGBUILD
@@ -1,56 +1,71 @@
-# Maintainer: Greg Helton <gt@fallendusk.org>
+# Maintainer: Heiko Baums <heiko@baums-on-web.de>
+# Contributor: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de>
pkgname=fbsplash
pkgver=1.5.4.3
-pkgrel=15
+pkgrel=33
pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
arch=('i686' 'x86_64')
url="http://fbsplash.berlios.de"
license=('GPL')
-backup=('etc/conf.d/fbsplash.conf' 'etc/conf.d/fbsplash.bootsteps')
-makedepends=('klibc')
-depends=('initscripts' 'miscsplashutils' 'libjpeg' 'libpng' 'freetype2-static' 'gpm' 'libmng' 'which' 'linhes-splash')
-conflicts=('bootsplash' 'gensplash')
+depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm' 'linhes-splash')
+optdepends=('kernel26-fbcondecor: enable console background images'
+ 'fbsplash-extras: additional functionality like daemon icons'
+ 'uswsusp-fbsplash: suspend to disk with fbsplash'
+ 'python: convert themes from splashy to fbsplash')
+conflicts=('fbsplash-scripts' 'initscripts-extras-fbsplash')
+options=('!makeflags')
+backup=('etc/conf.d/fbcondecor' 'etc/conf.d/splash')
install=fbsplash.install
-source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2 \
- http://code.thewrecker.net/files/darch.tar.bz2 \
- fbsplash.inithooks \
- splash-functions-arch.sh \
- fbsplash.conf \
- fbsplash.initcpio_install \
- fbsplash.daemon fbsplash.bootsteps)
+source=(http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${pkgver}.tar.bz2
+ fbsplash.git.patch
+ splash.conf
+ fbsplash-basic.sh
+ fbsplash.initcpio_install
+ fbsplash.initcpio_hook
+ fbcondecor.daemon
+ fbcondecor.conf)
+
build() {
- cd ${startdir}/src/splashutils-${pkgver}
-
- # Configure, make, and install
- ./configure --prefix=/usr --sysconfdir=/etc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
- make || return 1
- cp -f ${startdir}/splash-functions.sh ${startdir}/src/splashutils-1.5.4.3/scripts/splash-functions.sh
- make DESTDIR=${startdir}/pkg install || return 1
-
- # Create directories
- mkdir -p ${startdir}/pkg/lib/splash/cache
- mkdir -p ${startdir}/pkg/etc/splash
- mkdir -p ${startdir}/pkg/etc/rc.d/functions.d
-
- # Install scripts
- install -D -m644 ${startdir}/src/fbsplash.initcpio_install ${startdir}/pkg/lib/initcpio/install/fbsplash
- install -D -m644 ${startdir}/src/fbsplash.conf ${startdir}/pkg/etc/conf.d/fbsplash.conf
- install -D -m744 ${startdir}/src/fbsplash.daemon ${startdir}/pkg/etc/rc.d/fbsplash
- install -D -m744 ${startdir}/src/splash-functions-arch.sh ${startdir}/pkg/sbin/splash-functions-arch.sh
- install -D -m755 $startdir/src/fbsplash.bootsteps ${startdir}/pkg/etc/conf.d/fbsplash.bootsteps
-
- # install darch fbsplash theme
- cp -r ${startdir}/src/darch ${startdir}/pkg/etc/splash/darch
-
- # install initscripts hooks
- install -D -m744 ${startdir}/src/fbsplash.inithooks ${startdir}/pkg/etc/rc.d/functions.d/fbsplash.sh
+ cd ${srcdir}/splashutils-${pkgver}
+
+ # patch for building splashutils with glibc and dynamical linking
+ patch -Np0 -i ${srcdir}/fbsplash.git.patch || return 1
+ autoreconf
+
+ # fix fbcondecor_ctl splash type
+ sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
+
+ ./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ cd ${pkgdir}
+
+ # fix duplicate slashes to get splash_cache_cleanup grep to work
+ sed -r -e 's,^(export spl_.*="/)/+,\1,' -i sbin/splash-functions.sh
+
+ # fix the path to splash_util
+ sed -r -e 's,^(export spl_util=)\"/bin/,\1"/sbin/,' -i sbin/splash-functions.sh
+
+ # provide the mountpoint needed by splash-functions.sh
+ mkdir -p lib/splash/{cache,tmp}
+
+ # Install fbsplash scripts and config file
+ install -D -m644 ${srcdir}/splash.conf etc/conf.d/splash
+ install -D -m644 ${srcdir}/fbsplash-basic.sh etc/rc.d/functions.d/fbsplash-basic.sh
+ install -D -m644 ${srcdir}/fbsplash.initcpio_install lib/initcpio/install/fbsplash
+ install -D -m644 ${srcdir}/fbsplash.initcpio_hook lib/initcpio/hooks/fbsplash
+ # Install fbcodecor script and config file
+ install -D -m644 ${srcdir}/fbcondecor.conf etc/conf.d/fbcondecor
+ install -D -m755 ${srcdir}/fbcondecor.daemon etc/rc.d/fbcondecor
}
md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
- '4ea33e99330abf4a9a468ac8c0ba48ca'
- '33b3c7c2050670db0e8b2efd9e088ed9'
- '8ffb29400a2518b16f3dbca653855268'
- '82ef6f37c2795db1b4fec0e6f8443c66'
- '21380586a5dafbf7045886ea4374ab65'
- 'bb5154529e4b5fbc701cf4540c15a61a')
+ '3a338c60ed0710c8b7e3e08929db521a'
+ 'a8f40c99a32d20d505aa24fbbd703008'
+ 'e69753dac753b8ba4e2e29ef5a9c46ca'
+ 'e29b3db6ee059b9950febe976a0f2881'
+ 'ac2351bc918b101bb9249ce8940722be'
+ '715926469d05eecd345c052e6248ca32'
+ 'b3db9d4fd902b62ac9e38589677e2d16')