summaryrefslogtreecommitdiffstats
path: root/abs/core/fbsplash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fbsplash/PKGBUILD')
-rw-r--r--abs/core/fbsplash/PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/abs/core/fbsplash/PKGBUILD b/abs/core/fbsplash/PKGBUILD
index 3b25af8..fab0d28 100644
--- a/abs/core/fbsplash/PKGBUILD
+++ b/abs/core/fbsplash/PKGBUILD
@@ -2,39 +2,42 @@
# Contributor: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de>
pkgname=fbsplash
-pkgver=1.5.4.3
-pkgrel=38
+pkgver=1.5.4.4
+pkgrel=9
pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
arch=('i686' 'x86_64')
url="http://fbsplash.berlios.de"
license=('GPL')
depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm')
-optdepends=('kernel26-fbcondecor: enable console background images'
+optdepends=('linux-fbcondecor: enable console background images'
'fbsplash-extras: additional functionality like daemon icons'
'uswsusp-fbsplash: suspend to disk with fbsplash'
- 'python2: convert themes from splashy to fbsplash')
+ 'python: convert themes from splashy to fbsplash')
conflicts=('fbsplash-scripts' 'initscripts-extras-fbsplash')
options=('!makeflags')
backup=('etc/conf.d/fbcondecor' 'etc/conf.d/splash')
install=fbsplash.install
-source=(http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${pkgver}.tar.bz2
- fbsplash.git.patch
+source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2
+ splash_start_initcpio.patch
splash.conf
fbsplash-basic.sh
fbsplash.initcpio_install
fbsplash.initcpio_hook
fbcondecor.daemon
fbcondecor.conf)
+
build() {
cd ${srcdir}/splashutils-${pkgver}
- # patch for building splashutils with glibc and dynamical linking
- patch -Np0 -i ${srcdir}/fbsplash.git.patch
autoreconf
# fix fbcondecor_ctl splash type
sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
+ # fix set_event_dev call for initcpio usage (if evdev module is there)
+ #patch -Np2 -i ${srcdir}/splash_start_initcpio.patch
+
+ export LIBS="-lbz2"
./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
make
}
@@ -57,7 +60,7 @@ package() {
# Install fbsplash scripts and config file
install -D -m644 ${srcdir}/splash.conf etc/conf.d/splash
- install -D -m744 ${srcdir}/fbsplash-basic.sh etc/rc.d/functions.d/fbsplash-basic.sh
+ install -D -m644 ${srcdir}/fbsplash-basic.sh etc/rc.d/functions.d/fbsplash-basic.sh
install -D -m644 ${srcdir}/fbsplash.initcpio_install lib/initcpio/install/fbsplash
install -D -m644 ${srcdir}/fbsplash.initcpio_hook lib/initcpio/hooks/fbsplash
@@ -65,12 +68,11 @@ package() {
install -D -m644 ${srcdir}/fbcondecor.conf etc/conf.d/fbcondecor
install -D -m755 ${srcdir}/fbcondecor.daemon etc/rc.d/fbcondecor
}
-
-md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
- '3a338c60ed0710c8b7e3e08929db521a'
- '8f342632af1075667d6e11871a9e5d7e'
- 'e69753dac753b8ba4e2e29ef5a9c46ca'
- 'e29b3db6ee059b9950febe976a0f2881'
- 'ac2351bc918b101bb9249ce8940722be'
+md5sums=('2a16704c4adde97b58812cd89e3f2342'
+ '4045e315c52f5a576fca4f7e634eeb91'
+ 'c39f865e75192745759c8e95c7a7fd06'
+ 'a6b0b9c5c7a460380a7db127e0278164'
+ '24e2a7bbc2d18fe3ec10093665cd7a6e'
+ '4a3ac992a5042fa9770cbd3fdb7e1465'
'715926469d05eecd345c052e6248ca32'
'b3db9d4fd902b62ac9e38589677e2d16')