summaryrefslogtreecommitdiffstats
path: root/abs/core/fbsplash
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fbsplash')
-rw-r--r--abs/core/fbsplash/PKGBUILD78
-rw-r--r--abs/core/fbsplash/fbcondecor.conf6
-rw-r--r--abs/core/fbsplash/fbcondecor.daemon55
-rw-r--r--abs/core/fbsplash/fbsplash-basic.sh196
-rw-r--r--abs/core/fbsplash/fbsplash.initcpio_hook52
-rw-r--r--abs/core/fbsplash/fbsplash.initcpio_install104
-rw-r--r--abs/core/fbsplash/fbsplash.install27
-rw-r--r--abs/core/fbsplash/splash.conf72
-rw-r--r--abs/core/fbsplash/splash_start_initcpio.patch22
9 files changed, 0 insertions, 612 deletions
diff --git a/abs/core/fbsplash/PKGBUILD b/abs/core/fbsplash/PKGBUILD
deleted file mode 100644
index fab0d28..0000000
--- a/abs/core/fbsplash/PKGBUILD
+++ /dev/null
@@ -1,78 +0,0 @@
-# Maintainer: Heiko Baums <heiko@baums-on-web.de>
-# Contributor: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de>
-
-pkgname=fbsplash
-pkgver=1.5.4.4
-pkgrel=9
-pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
-arch=('i686' 'x86_64')
-url="http://fbsplash.berlios.de"
-license=('GPL')
-depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm')
-optdepends=('linux-fbcondecor: enable console background images'
- 'fbsplash-extras: additional functionality like daemon icons'
- 'uswsusp-fbsplash: suspend to disk with fbsplash'
- 'python: convert themes from splashy to fbsplash')
-conflicts=('fbsplash-scripts' 'initscripts-extras-fbsplash')
-options=('!makeflags')
-backup=('etc/conf.d/fbcondecor' 'etc/conf.d/splash')
-install=fbsplash.install
-source=(http://download.berlios.de/fbsplash/splashutils-${pkgver}.tar.bz2
- splash_start_initcpio.patch
- splash.conf
- fbsplash-basic.sh
- fbsplash.initcpio_install
- fbsplash.initcpio_hook
- fbcondecor.daemon
- fbcondecor.conf)
-
-build() {
- cd ${srcdir}/splashutils-${pkgver}
-
- autoreconf
-
- # fix fbcondecor_ctl splash type
- sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
-
- # fix set_event_dev call for initcpio usage (if evdev module is there)
- #patch -Np2 -i ${srcdir}/splash_start_initcpio.patch
-
- export LIBS="-lbz2"
- ./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
- make
-}
-
-package() {
- cd ${srcdir}/splashutils-${pkgver}
-
- make DESTDIR=${pkgdir} install
-
- cd ${pkgdir}
-
- # fix duplicate slashes to get splash_cache_cleanup grep to work
- sed -r -e 's,^(export spl_.*="/)/+,\1,' -i sbin/splash-functions.sh
-
- # fix the path to splash_util
- sed -r -e 's,^(export spl_util=)\"/bin/,\1"/sbin/,' -i sbin/splash-functions.sh
-
- # provide the mountpoint needed by splash-functions.sh
- mkdir -p lib/splash/{cache,tmp}
-
- # Install fbsplash scripts and config file
- install -D -m644 ${srcdir}/splash.conf etc/conf.d/splash
- install -D -m644 ${srcdir}/fbsplash-basic.sh etc/rc.d/functions.d/fbsplash-basic.sh
- install -D -m644 ${srcdir}/fbsplash.initcpio_install lib/initcpio/install/fbsplash
- install -D -m644 ${srcdir}/fbsplash.initcpio_hook lib/initcpio/hooks/fbsplash
-
- # Install fbcodecor script and config file
- install -D -m644 ${srcdir}/fbcondecor.conf etc/conf.d/fbcondecor
- install -D -m755 ${srcdir}/fbcondecor.daemon etc/rc.d/fbcondecor
-}
-md5sums=('2a16704c4adde97b58812cd89e3f2342'
- '4045e315c52f5a576fca4f7e634eeb91'
- 'c39f865e75192745759c8e95c7a7fd06'
- 'a6b0b9c5c7a460380a7db127e0278164'
- '24e2a7bbc2d18fe3ec10093665cd7a6e'
- '4a3ac992a5042fa9770cbd3fdb7e1465'
- '715926469d05eecd345c052e6248ca32'
- 'b3db9d4fd902b62ac9e38589677e2d16')
diff --git a/abs/core/fbsplash/fbcondecor.conf b/abs/core/fbsplash/fbcondecor.conf
deleted file mode 100644
index 18db844..0000000
--- a/abs/core/fbsplash/fbcondecor.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-
-# /etc/conf.d/fbcondecor
-#
-
-## Virtual terminals to load with fbcondecor backgrounds
-SPLASH_TTYS="1 2 3 4 5 6"
diff --git a/abs/core/fbsplash/fbcondecor.daemon b/abs/core/fbsplash/fbcondecor.daemon
deleted file mode 100644
index 4d78ea4..0000000
--- a/abs/core/fbsplash/fbcondecor.daemon
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/bash
-
-# /etc/rc.d/fbcondecor
-
-# Set FbConDecor backgrounds
-#
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/fbcondecor
-. /sbin/splash-functions.sh
-
-splash_setup force
-
-retval=0
-[ -z "${SPLASH_TTYS%% }" ] && retval=1
-case "$1"
-in start )
- if [ "${SPLASH_MODE_REQ}" != "off" ]; then
- stat_busy "Setting FBconDecor console images"
- for tty in ${SPLASH_TTYS}; do
- # avoid blinking on boot
- [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ on ]] && continue
- fbcondecor_set_theme ${SPLASH_THEME} ${tty} || retval=1
- done
- if [ $retval = 0 ]; then
- stat_done
- else
- stat_fail
- fi
- fi
-;; stop )
- stat_busy "Disabling FBconDecor console images"
- for tty in ${SPLASH_TTYS}; do
- # avoid errors on restart
- [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ off ]] && continue
- fbcondecor_ctl --tty=${tty} -c off || retval=1
- done
- if [ $retval = 0 ]; then
- stat_done
- else
- stat_fail
- fi
-;; restart )
- $0 stop
- sleep .1
- echo # don't swallow our status line
- $0 start
-;; * )
- echo "usage: $0 {start|stop|restart}"
-esac
-
-exit 0
-
-# EOF #
diff --git a/abs/core/fbsplash/fbsplash-basic.sh b/abs/core/fbsplash/fbsplash-basic.sh
deleted file mode 100644
index 4403b86..0000000
--- a/abs/core/fbsplash/fbsplash-basic.sh
+++ /dev/null
@@ -1,196 +0,0 @@
-
-# /etc/rc.d/functions.d/fbsplash-basic.sh #
-
-# Basic Fbsplash script for Arch Linux initscripts #
-# #
-# Author: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de> #
-# Based on the work of Greg Helton <gt at fallendusk.org> #
-# Thomas Baechler <thomas at archlinux.org> #
-# and others #
-# #
-# Distributed under the terms of the GNU General Public License (GPL) #
-
-[[ $PREVLEVEL && $RUNLEVEL ]] || return 0
-
-# Do nothing if advanced script is installed
-[[ -r /etc/rc.d/functions.d/fbsplash-extras.sh ]] && return
-
-# Only do this where needed
-# Since we use BASH, all important functions and variables are exported
-case ${0#/etc/rc.} in sysinit | multi | shutdown )
- # splash-functions.sh will run splash_setup which needs /proc
- # code line copied from /etc/rc.sysinit
- /bin/mountpoint -q /proc || /bin/mount -n -t proc proc /proc -o nosuid,noexec,nodev
- export SPLASH_PUSH_MESSAGES SPLASH_VERBOSE_ON_ERRORS
- . /sbin/splash-functions.sh # /etc/conf.d/splash is also sourced by this
- unset options opt i # eliminate splash_setup non local vars ## FIX ME ##
- SPLASH_STEPS=3 # sysinit steps
- SPLASH_STEPS_DONE=0
-esac
-
-# Verbose mode is handled by fbcondecor kernel patch and daemon script
-[[ $SPLASH_MODE_REQ = silent ]] || return 0
-
-# Override - Don't try to use /usr/bin/basename
-splash_comm_send() {
- [[ $( /bin/pidof -o %PPID $spl_daemon ) ]] && echo "$@" >$spl_fifo &
-}
-
-case $0 in /etc/rc.sysinit )
- # Prevent splash destruction
- CONSOLEFONT=""
- # Continue to use a splash daamon started in initcpio
- if /bin/mountpoint -q /run/.splash-cache; then
- /bin/mount --move /run/.splash-cache $spl_cachedir || return
- splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
- # Mount a tmpfs
- else
- ( splash_cache_prep ) || return
- fi
- add_hook sysinit_udevsettled splash_sysinit_udevsettled
- add_hook sysinit_postfsck splash_sysinit_postfsck
- add_hook sysinit_postfsckloop splash_sysinit_postfsck
- add_hook sysinit_premount splash_sysinit_premount
- add_hook sysinit_end splash_sysinit_end
- splash_sysinit_udevsettled() {
- splash_begin
- splash_progress_init
- splash_progress
- }
- splash_sysinit_premount() {
- splash_progress
- }
- splash_sysinit_postfsck() { # fsck failure emergency exit
- (( fsckret > 1 && fsckret != 32 )) && chvt 1
- }
- splash_sysinit_end() {
- splash_progress
- }
-;; /etc/rc.multi )
- add_hook multi_start splash_multi_start
- add_hook multi_end splash_multi_end
- splash_multi_start() {
- SPLASH_STEPS_DONE=$SPLASH_STEPS
- splash_progress_init
- }
- start_daemon() {
- [[ $1 = $SPLASH_XSERVICE ]] && SPLASH_EXIT_TYPE=staysilent splash_stop
- /etc/rc.d/$1 start
- splash_progress
- }
- start_daemon_bkgd() {
- [[ $1 = $SPLASH_XSERVICE ]] && SPLASH_EXIT_TYPE=staysilent splash_stop
- stat_bkgd "Starting $1"
- ( SPLASH_PUSH_MESSAGES="no" SPLASH_VERBOSE_ON_ERRORS="no" \
- /etc/rc.d/$1 start ) &>/dev/null &
- }
- splash_multi_end() {
- if [[ $PREVLEVEL = N ]]; then
- if ! in_array "$SPLASH_XSERVICE" "${DAEMONS[@]}"; then
- if [[ $RUNLEVEL = 5 ]]; then
- SPLASH_EXIT_TYPE=staysilent splash_stop
- else
- splash_stop
- [[ $( $spl_bindir/fgconsole ) = $SPLASH_TTY ]] && chvt 1
- fi
- fi
- # Now do setfont
- set_consolefont
- # Umount the tmpfs
- splash_cache_cleanup
- fi
- }
-;; /etc/rc.shutdown )
- ( splash_cache_prep ) || return
- # Not using XSERVICE here to avoid missing errors - X should chvt back to SPLASH_TTY
- add_hook shutdown_start splash_shutdown_start
- add_hook shutdown_prekillall splash_shutdown_prekillall
- add_hook shutdown_postkillall splash_shutdown_postkillall
- add_hook shutdown_poweroff splash_shutdown_poweroff
- splash_shutdown_start() {
- splash_begin
- }
- splash_shutdown_prekillall() {
- splash_comm_send progress $(( 65535*1/3 )); splash_comm_send paint
- [[ -r $spl_pidfile ]] && add_omit_pids $( <$spl_pidfile )
- }
- splash_shutdown_postkillall() {
- splash_comm_send progress $(( 65535*2/3 )); splash_comm_send paint
- }
- splash_shutdown_poweroff() {
- SPLASH_EXIT_TYPE=staysilent splash_stop
- }
-esac
-
-splash_progress_init() {
- for daemon in "${DAEMONS[@]}"; do
- case $daemon in $SPLASH_XSERVICE | @$SPLASH_XSERVICE ) break
- ;; \!* |@* ) continue
- esac
- (( SPLASH_STEPS++ ))
- done
-}
-
-splash_progress() {
- splash_comm_send progress $(( 65535*++SPLASH_STEPS_DONE/SPLASH_STEPS ))
- splash_comm_send paint
-}
-
-# Start the splash daemon - using upstream function
-splash_begin() {
- if ! [[ $( /bin/pidof -o %PPID $spl_daemon ) ]]; then
- stat_busy "Starting Fbsplash daemon"
- if [ -x /etc/splash/$SPLASH_THEME/scripts/rc_init-pre ]; then
- /etc/splash/$SPLASH_THEME/scripts/rc_init-pre ${0#/etc/rc.d} $RUNLEVEL
- fi &&
- splash_start &&
- stat_done || stat_fail
- fi
-}
-
-# Stop the splash daemon - if any
-splash_stop() {
- if [[ $( /bin/pidof -o %PPID $spl_daemon ) ]]; then
- SPLASH_PUSH_MESSAGES="no" stat_busy "Stopping Fbsplash daemon"
- splash_comm_send progress 65535; splash_comm_send paint; /bin/sleep .1
- splash_comm_send exit $SPLASH_EXIT_TYPE
- # Wait for painting/fadeout
- local -i i=0
- while [[ i++ -lt 100 && $( /bin/pidof -o %PPID $spl_daemon ) ]]; do
- /bin/sleep .1
- done
- stat_done
- fi
-}
-
-stat_busy() {
- printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
- printf "${SAVE_POSITION}"
- deltext
- printf " ${C_OTHER}[${C_BUSY}BUSY${C_OTHER}]${C_CLEAR} "
- SPLASH_BUSY_MSG=$1
- if [[ $SPLASH_PUSH_MESSAGES = yes ]]; then
- splash_comm_send set message "${1}"
- splash_comm_send paint
- fi
-}
-
-stat_fail() {
- deltext
- printf " ${C_OTHER}[${C_FAIL}FAIL${C_OTHER}]${C_CLEAR} \n"
- local event=stop_failed; [[ $PREVLEVEL = N ]] && event=start_failed
- # Provide a general failure status event and write to msglog textbox
- splash_comm_send update_svc fbsplash-dummy svc_${event}
- splash_comm_send log "Error $SPLASH_BUSY_MSG"
- splash_comm_send paint
- # Save for daemon restart ## FIX ME ##
- if /bin/mountpoint -q $spl_cachedir; then
- : >|$spl_cachedir/${event}-fbsplash-dummy
- fi
- # Upstream way of error handling
- if [[ $SPLASH_VERBOSE_ON_ERRORS = yes ]]; then
- chvt 1
- fi
-}
-
-# EOF #
diff --git a/abs/core/fbsplash/fbsplash.initcpio_hook b/abs/core/fbsplash/fbsplash.initcpio_hook
deleted file mode 100644
index 02617a2..0000000
--- a/abs/core/fbsplash/fbsplash.initcpio_hook
+++ /dev/null
@@ -1,52 +0,0 @@
-run_hook ()
-{
- # avoid exporting configuration
- (
- SPLASH_INIT_MESSAGE="Initializing the kernel"
- # Get configuration and functions (faking sysinit for config file hacks)
- PREVLEVEL=N; RUNLEVEL=S
- . /sbin/splash-functions.sh
- unset PREVLEVEL RUNLEVEL
-
- [ "${SPLASH_MODE_REQ}" = "silent" ] || exit 0
-
- # Start the daemon here if possible
- # to show animations early and gain some bootup speed
- if [ -x "$spl_daemon" ]; then
- msg "Starting Fbsplash Daemon"
- set -e
- # Mount the cache within /run to get it moved to the new root
- mkdir /run/.splash-cache
- ( spl_cachedir=/run/.splash-cache; splash_cache_prep )
- # Take over any existing cache content
- mkdir -p $spl_cachedir
- parent=$( dirname $spl_cachedir )
- mv $spl_cachedir $parent/.splash-cache
- cp -a $parent/.splash-cache /run/
- # Symlink for starting the daemon
- ln -s /run/.splash-cache $spl_cachedir
- # Wait for any fbcondecor fadein - may take very long on some broken systems
- i=0
- while [ -n "$( pidof fbcondecor_helper )" ]; do
- if [ $i -ge 50 ]; then
- err "timeout on waiting for fbcondecor_helper to die!"
- exit 1
- fi
- sleep .1
- i=$(( i + 1 ))
- done
- # Actually start the daemon
- cd /run/.splash-cache
- set +e
- SPLASH_BOOT_MESSAGE="${SPLASH_INIT_MESSAGE}"
- splash_start && sleep .1 # allow the daemon to open the event dev
- exit
- fi
-
- # Start the fbcondecor helper if not already done by fbcondecor kernel
- if ! fbcondecor_supported; then
- BOOT_MSG="${SPLASH_INIT_MESSAGE}" \
- /sbin/fbcondecor_helper 2 init 0 0 $SPLASH_THEME
- fi
- )
-}
diff --git a/abs/core/fbsplash/fbsplash.initcpio_install b/abs/core/fbsplash/fbsplash.initcpio_install
deleted file mode 100644
index 841405b..0000000
--- a/abs/core/fbsplash/fbsplash.initcpio_install
+++ /dev/null
@@ -1,104 +0,0 @@
-
-build() {
- # Add config file, splash-functions and the helper
- add_file /etc/conf.d/splash
- add_file /sbin/splash-functions.sh
- add_binary /sbin/fbcondecor_helper
-
- # Get in configuration, parameters and functions
- . /etc/conf.d/splash
- . /sbin/splash-functions.sh
-
- # Unmount any stale cache tmpfs
- splash_cache_cleanup
-
- SPLASH_PROFILE=off
-
- if [[ $SPLASH_DAEMON = early ]]; then
- # Add stuff needed to run splash_start function (except optional evdev module)
- add_dir $spl_tmpdir
- add_binary $spl_daemon
- if [[ -e /etc/rc.d/functions.d/fbsplash-extras.sh ]]; then
- . /etc/rc.d/functions.d/fbsplash-extras.sh
- # Add files from a prepared cache (faking sysinit)
- splash_cache_prep_initcpio && add_full_dir $spl_cachedir
- fi
- fi
-
- # List file paths contained in given Fbsplash theme cfg files
- # (Only file paths containing at least one slash will be found by this.)
- fbsplash_list_paths() {
- (( $# )) || return 0
- /bin/sed -re '
- # convert all whitespace into single blanks
- s,[[:space:]]+, ,g ; t L1
- :L1
- # drop comments, grouping directives and blank lines
- /^ *([#<]|$)/ d
- # get a filepath or drop
- s,.*[ =]([^ ]*/[^ ]+).*,\1, ; t ; d
- ' "$@" | /usr/bin/sort -u
- }
-
- # Check if arg is a theme cfg file path
- fbsplash_is_cfg() {
- [[ $1 =~ ^/etc/splash/[^/]+/[0-9]+x[0-9]+\.cfg$ ]]
- }
-
- # Add all files referenced by path in given theme cfg files
- # args: <theme-root-dir> <cfg-file>...
- fbsplash_add_files_from_cfgs() {
- local file theme_dir=$1; shift
- while read file; do
- if [[ $file == /* ]]; then
- add_file $file
- else # Path may be relative to /etc/splash or theme-dir
- local found=0
- for file in /etc/splash/$file "$theme_dir"/$file; do
- [[ -f $file ]] && { add_file $file; found=1; }
- done
- (( found )) || error "Theme '${theme_dir##*/}': File not found: '$file'"
- fi
- done < <( fbsplash_list_paths "$@" )
- }
-
- # Add common files (may be referenced in cfg by plain file name)
- local file
- for file in /etc/splash/*; do
- [[ -f $file ]] && add_file "$file"
- done
-
- # Add themes
- local file theme
- for theme in $SPLASH_THEMES; do
- if [[ -d /etc/splash/$theme && $theme != */* ]]; then
- add_full_dir /etc/splash/$theme
- local files=()
- for file in /etc/splash/$theme/*.cfg; do
- [[ -f $file ]] && fbsplash_is_cfg "$file" && files+=( $file )
- done
- fbsplash_add_files_from_cfgs /etc/splash/$theme "${files[@]}"
- elif [[ -f /etc/splash/$theme ]] && fbsplash_is_cfg /etc/splash/$theme; then
- file=/etc/splash/$theme; theme=${theme%/*}
- add_file $file
- fbsplash_add_files_from_cfgs /etc/splash/$theme $file
- # Add all non-cfg files from theme dir (may be referenced by plain file name)
- for file in /etc/splash/$theme/*; do
- [[ -f $file ]] && ! fbsplash_is_cfg "$file" && add_file "$file"
- done
- else
- error "Theme invalid or not found: '$theme'"
- fi
- done
-
- SCRIPT="fbsplash"
-}
-
-help() {
-cat<<HELPEOF
- This hook adds the FBconDecor helper and Fbsplash themes and maybe the
- Fbsplash daemon as specified in /etc/conf.d/splash.
-HELPEOF
-}
-
-#EOF
diff --git a/abs/core/fbsplash/fbsplash.install b/abs/core/fbsplash/fbsplash.install
deleted file mode 100644
index 09da219..0000000
--- a/abs/core/fbsplash/fbsplash.install
+++ /dev/null
@@ -1,27 +0,0 @@
-post_install() {
- echo "------------------------------------------------------------"
- echo "> This package doesn't contain a default theme."
- echo "> You need to install one separately."
- echo "> To find some themes, just search AUR for \"fbsplash-theme\","
- echo "> or GNOME-Look.org or KDE-Look.org for \"fbsplash\"."
- echo "------------------------------------------------------------"
- echo "> Configuration for fbsplash: /etc/conf.d/splash"
- echo "> Configuration for fbcondecor: /etc/conf.d/fbcondecor"
- echo "------------------------------------------------------------"
- echo "> Remember to rebuild the initrd after changing the"
- echo "> configuration."
- echo "------------------------------------------------------------"
- echo "> Please read http://wiki.archlinux.org/index.php/Fbsplash"
- echo "> for more details. "
- echo "------------------------------------------------------------"
-}
-
-post_upgrade() {
- post_install
-}
-
-op=$1
-shift
-$op $*
-
-#EOF
diff --git a/abs/core/fbsplash/splash.conf b/abs/core/fbsplash/splash.conf
deleted file mode 100644
index 44fed88..0000000
--- a/abs/core/fbsplash/splash.conf
+++ /dev/null
@@ -1,72 +0,0 @@
-#
-# /etc/conf.d/splash
-#
-
-#### WARNING!
-## This file is also sourced in the initcpio hook.
-## No BASH-code (like arrays) is allowed here!
-
-#### initcpio and Fbsplash daemon ##########################################
-
-## Themes to include into initcpio
-## For a smaller initcpio you may try theme cfg files instead of directories.
-SPLASH_THEMES="
- linhes
-"
-
-## Override the initial silent splash screen status message defaults.
-## Note: '$progress' will be replaced by Fbsplash itself.
-## * initcpio - (no effect with fbcondecor kernel)
-SPLASH_INIT_MESSAGE="Initializing the kernel..."
-## * bootup
-SPLASH_BOOT_MESSAGE="Booting $HOSTNAME..."
-## * reboot
-SPLASH_REBOOT_MESSAGE="Rebooting $HOSTNAME..."
-## * shutdown
-SPLASH_SHUTDOWN_MESSAGE="Shutting down $HOSTNAME..."
-
-## Include and use the Fbsplash daemon (1.5 MiB) in the initcpio
-## instead of the small helper only.
-## Usefull to show animations early.
-## Note: Themes with 'scripts/rc_init-pre' like 'arch-banner-icons' are
-## supported now if fbsplash-extras>=2.0.10 is installed, but there
-## might still be some sophisticated ones which break when using this.
-SPLASH_DAEMON="early"
-
-## Make the splash daemon use fade effects.
-## Note: The initcpio helper does only use the kernel parameter!
-# Just use fadein on bootup and fadeout on shutdown/reboot
-#case $PREVLEVEL in N ) SPLASH_EFFECTS="fadein" ; esac
-#case $RUNLEVEL in [06] ) SPLASH_EFFECTS="fadeout"; esac
-# Uncomment this line to allways use both
-# SPLASH_EFFECTS="fadein,fadeout"
-
-## Enable the textbox when starting the Fbsplash daemon.
-## Useful if the theme provides a message log or other textbox.
-## The scripts write any initscripts [FAIL] messages to the log.
-## Note: The textbox can also be toggled by pressing F3-key.
-SPLASH_TEXTBOX="yes"
-
-## Splash progress timeout
-## If set to a positive value, Fbsplash will automatically switch to verbose
-## mode if there is no progress for the specified number of seconds.
-SPLASH_AUTOVERBOSE=0
-
-#### scripts behaviour #####################################################
-
-## Change to verbose mode on any initscripts [FAIL] message
-## Useful with very simple themes and also when starting Xorg from DAEMONS
-SPLASH_VERBOSE_ON_ERRORS="no"
-
-## Name of the DAEMONS script starting Xorg if any
-## Set this to avoid virtual terminal change struggle between X and Fbsplash.
-#SPLASH_XSERVICE="gdm"
-#SPLASH_XSERVICE="kdm"
-#SPLASH_XSERVICE="xdm"
-#SPLASH_XSERVICE="lxdm"
-#SPLASH_XSERVICE="slim"
-
-## Push initscripts [BUSY] messages to the splash status message line.
-SPLASH_PUSH_MESSAGES="no"
-
-# EOF #
diff --git a/abs/core/fbsplash/splash_start_initcpio.patch b/abs/core/fbsplash/splash_start_initcpio.patch
deleted file mode 100644
index ff4ae96..0000000
--- a/abs/core/fbsplash/splash_start_initcpio.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -ru src.orig//splashutils-1.5.4.3/scripts/splash-functions.sh.in src//splashutils-1.5.4.3/scripts/splash-functions.sh.in
---- src.orig//splashutils-1.5.4.3/scripts/splash-functions.sh.in 2008-11-13 20:54:19.000000000 +0100
-+++ src//splashutils-1.5.4.3/scripts/splash-functions.sh.in 2011-03-03 09:45:29.258901793 +0100
-@@ -250,6 +250,9 @@
- # Start the splash daemon
- BOOT_MSG="$(splash_get_boot_message)" ${spl_daemon} --theme="${SPLASH_THEME}" --pidfile="${spl_pidfile}" --type=${ttype} ${options}
-
-+ # First let the daemon open the event dev before it's gone away in case this is run in the initcpio
-+ splash_set_event_dev
-+
- # Set the silent TTY and boot message
- splash_comm_send "set tty silent ${SPLASH_TTY}"
-
-@@ -261,8 +264,6 @@
-
- splash_comm_send "set autoverbose ${SPLASH_AUTOVERBOSE}"
-
-- splash_set_event_dev
--
- return 0
- }
-