summaryrefslogtreecommitdiffstats
path: root/abs/core/ffmpeg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ffmpeg/PKGBUILD')
-rw-r--r--abs/core/ffmpeg/PKGBUILD63
1 files changed, 37 insertions, 26 deletions
diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 115ddfb..8f3e9d7 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -1,33 +1,39 @@
# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg
-pkgver=2.4.3
-pkgrel=1
+pkgver=2.8.5
+pkgrel=2
epoch=1
-pkgdesc='Complete and free Internet live audio and video broadcasting solution'
+pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
-license=('GPL')
-depends=(
- 'alsa-lib' 'bzip2' 'fontconfig' 'gnutls' 'gsm' 'lame' 'libass' 'libvdpau'
- 'libbluray' 'libmodplug' 'libtheora' 'libva' 'libvorbis' 'libvpx'
- 'opencore-amr' 'openjpeg' 'opus' 'rtmpdump' 'schroedinger' 'sdl' 'speex'
- 'v4l-utils' 'libx264' 'xvidcore' 'zlib' 'x265' 'fribidi'
-)
-makedepends=('libvdpau' 'yasm')
-source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
-md5sums=('8da635baff57d7ab704b1daca5a99b47'
- 'SKIP')
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
+ 'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
+ 'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
+ 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so')
+source=(http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2{,.asc})
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+sha256sums=('3b6d9951533323ee64a21d0aa7667a780b3470bfe4e0fb7c1b33307ce290615a'
+ 'SKIP')
build() {
- cd $pkgname-$pkgver
+ cd ffmpeg-${pkgver}
./configure \
- --prefix=/usr \
+ --prefix='/usr' \
--disable-debug \
--disable-static \
--disable-stripping \
@@ -36,8 +42,10 @@ build() {
--enable-fontconfig \
--enable-gnutls \
--enable-gpl \
+ --enable-ladspa \
--enable-libass \
--enable-libbluray \
+ --enable-libdcadec \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
@@ -48,22 +56,22 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--disable-libpulse \
- --enable-librtmp \
--enable-libschroedinger \
+ --enable-libsoxr \
--enable-libspeex \
+ --enable-libssh \
--enable-libtheora \
--enable-libv4l2 \
+ --enable-libvidstab \
--enable-libvorbis \
--enable-libvpx \
+ --enable-libwebp \
--enable-libx264 \
--enable-libx265 \
--enable-libxvid \
- --enable-runtime-cpudetect \
--enable-shared \
- --enable-swresample \
- --enable-vdpau \
--enable-version3 \
- --enable-x11grab \
+ --enable-x11grab
make
make tools/qt-faststart
@@ -71,7 +79,10 @@ build() {
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install install-man
- install -Dm755 tools/qt-faststart "$pkgdir"/usr/bin/qt-faststart
+ cd ffmpeg-${pkgver}
+
+ make DESTDIR="${pkgdir}" install install-man
+ install -Dm 755 tools/qt-faststart "${pkgdir}"/usr/bin/
}
+
+# vim: ts=2 sw=2 et: