summaryrefslogtreecommitdiffstats
path: root/abs/core/fluxbox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fluxbox/PKGBUILD')
-rw-r--r--abs/core/fluxbox/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/abs/core/fluxbox/PKGBUILD b/abs/core/fluxbox/PKGBUILD
index b3a9a41..3873ff1 100644
--- a/abs/core/fluxbox/PKGBUILD
+++ b/abs/core/fluxbox/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=fluxbox
pkgver=1.1.1
-pkgrel=6
+pkgrel=11
pkgdesc="A lightweight and highly-configurable window manager"
arch=('i686' 'x86_64')
url="http://www.fluxbox.org"
@@ -13,9 +13,11 @@ depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'bash' 'imlib2')
makedepends=('pkgconfig')
options=('!makeflags')
source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2 \
- fluxbox.desktop keys)
+ fluxbox.desktop keys fluxbox_fullscreen_focus.patch)
build() {
+ echo "==> Patching Fluxbox with fullscreen focus patch..."
+ patch < fluxbox_fullscreen_focus.patch ${srcdir}/${pkgname}-${pkgver}/src/Window.cc || return 1
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr \
--enable-kde --enable-gnome \
@@ -29,3 +31,7 @@ build() {
install -D -m644 ../keys ${pkgdir}/usr/share/fluxbox/keys || return 1
install -D -m644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING || return 1
}
+md5sums=('fa9fa8fe9a44f86522de5754f8b285ca'
+ 'eeae9c88a2526ac0bd8afcd9ce97f9ed'
+ 'bb9f812c559263b4bf1d722628a11ca8'
+ '82dac089f2d42bb9592debc93291846d')