summaryrefslogtreecommitdiffstats
path: root/abs/core/fontconfig/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fontconfig/PKGBUILD')
-rw-r--r--abs/core/fontconfig/PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/abs/core/fontconfig/PKGBUILD b/abs/core/fontconfig/PKGBUILD
index 9f1fe17..e15ebc6 100644
--- a/abs/core/fontconfig/PKGBUILD
+++ b/abs/core/fontconfig/PKGBUILD
@@ -2,39 +2,33 @@
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=fontconfig
-pkgver=2.11.1
-pkgrel=2
+pkgver=2.12.1
+pkgrel=4
pkgdesc="A library for configuring and customizing font access"
arch=(i686 x86_64)
-url="http://www.fontconfig.org/release/"
+url="https://www.freedesktop.org/wiki/Software/fontconfig/"
license=('custom')
depends=('expat' 'freetype2')
+makedepends=('python2' 'docbook2x')
install=fontconfig.install
-source=(http://www.fontconfig.org/release/$pkgname-$pkgver.tar.bz2
- 0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch
- 0002-Update-aliases-for-new-URW-fonts.patch)
-sha256sums=('dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99'
- '657d180d9d78555df4f1b81871ba9c1c7c6056c83455514950d064fdfae4646b'
- '1194d1b92d228d8ed705f5502fdf4fcfad5a794f388bcb4928074df4c34a1bfb')
+source=(https://www.freedesktop.org/software/$pkgname/release/$pkgname-$pkgver.tar.bz2
+ fontconfig.hook
+ 0001-fix-test-with-freetype2-2.7.1.patch)
+sha256sums=('b449a3e10c47e1d1c7a6ec6e2016cca73d3bd68fbbd4f0ae5cc6b573f7d6c7f3'
+ '672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274'
+ 'b4992aab4e2b4ddae01f7565486752fa877edb6cd5ed435e15938ed21dfe22c8')
- # a nice page to test font matching:
- # http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+# a nice page to test font matching:
+# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+# http://getemoji.com/
prepare() {
cd $pkgname-$pkgver
-
- # Upstream patches implementing FS#45928
- patch -p1 -i ../0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch
- patch -p1 -i ../0002-Update-aliases-for-new-URW-fonts.patch
+ patch -Np1 -i ../0001-fix-test-with-freetype2-2.7.1.patch
}
build() {
cd $pkgname-$pkgver
-
- # make sure there's no rpath trouble and sane .so versioning - FC and Gentoo do this as well
- libtoolize -f
- autoreconf -fi
-
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-templatedir=/etc/fonts/conf.avail \
@@ -51,8 +45,14 @@ check() {
make -k check
}
+_install_conf() {
+ install -m644 "$1" "$pkgdir/etc/fonts/conf.avail"
+ ln -s "../conf.avail/${1##*/}" "$pkgdir/etc/fonts/conf.d"
+}
+
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 ../fontconfig.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig.hook"
}