summaryrefslogtreecommitdiffstats
path: root/abs/core/fontconfig/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/fontconfig/PKGBUILD')
-rw-r--r--abs/core/fontconfig/PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/abs/core/fontconfig/PKGBUILD b/abs/core/fontconfig/PKGBUILD
index 2919bb1..9f1fe17 100644
--- a/abs/core/fontconfig/PKGBUILD
+++ b/abs/core/fontconfig/PKGBUILD
@@ -3,19 +3,31 @@
pkgname=fontconfig
pkgver=2.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="A library for configuring and customizing font access"
arch=(i686 x86_64)
url="http://www.fontconfig.org/release/"
license=('custom')
depends=('expat' 'freetype2')
install=fontconfig.install
-source=(http://www.fontconfig.org/release/$pkgname-$pkgver.tar.bz2)
-sha256sums=('dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99')
+source=(http://www.fontconfig.org/release/$pkgname-$pkgver.tar.bz2
+ 0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch
+ 0002-Update-aliases-for-new-URW-fonts.patch)
+sha256sums=('dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99'
+ '657d180d9d78555df4f1b81871ba9c1c7c6056c83455514950d064fdfae4646b'
+ '1194d1b92d228d8ed705f5502fdf4fcfad5a794f388bcb4928074df4c34a1bfb')
# a nice page to test font matching:
# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Upstream patches implementing FS#45928
+ patch -p1 -i ../0001-Revert-Bug-73291-poppler-does-not-show-fl-ligature.patch
+ patch -p1 -i ../0002-Update-aliases-for-new-URW-fonts.patch
+}
+
build() {
cd $pkgname-$pkgver