summaryrefslogtreecommitdiffstats
path: root/abs/core/gdb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gdb/PKGBUILD')
-rw-r--r--abs/core/gdb/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/abs/core/gdb/PKGBUILD b/abs/core/gdb/PKGBUILD
index d96cb93..6e0648b 100644
--- a/abs/core/gdb/PKGBUILD
+++ b/abs/core/gdb/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 90312 2010-09-10 14:58:18Z allan $
+# $Id: PKGBUILD 172148 2012-11-30 04:20:34Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gdb
-pkgver=7.2
-pkgrel=2
+pkgver=7.5.1
+pkgrel=1
pkgdesc="The GNU Debugger"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gdb/"
@@ -14,24 +14,23 @@ makedepends=('texinfo')
backup=('etc/gdb/gdbinit')
options=('!libtool')
install=gdb.install
-source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('64260e6c56979ee750a01055f16091a5')
+source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2{,.sig})
+md5sums=('3f48f468b24447cf24820054ff6e85b1'
+ '31ab569c78a01d3f946c6fe0336175fe')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr --disable-nls \
--with-system-readline \
+ --with-python=/usr/bin/python2 \
--with-system-gdbinit=/etc/gdb/gdbinit
- make || return 1
-
- # requires dejagnu
- #make check
+ make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
# install "custom" system gdbinit
install -dm755 $pkgdir/etc/gdb