summaryrefslogtreecommitdiffstats
path: root/abs/core/ghostscript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ghostscript/PKGBUILD')
-rw-r--r--abs/core/ghostscript/PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/abs/core/ghostscript/PKGBUILD b/abs/core/ghostscript/PKGBUILD
index f27e992..42dada7 100644
--- a/abs/core/ghostscript/PKGBUILD
+++ b/abs/core/ghostscript/PKGBUILD
@@ -4,28 +4,41 @@
### !!! rebuild groff from core that picks up hardcoding the GS versioned font path !!! ###
pkgname=ghostscript
-pkgver=9.15
-pkgrel=1
+pkgver=9.18
+pkgrel=6
pkgdesc="An interpreter for the PostScript language"
arch=('i686' 'x86_64')
license=('AGPL' 'custom')
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
-makedepends=('gtk3' 'gnutls')
+makedepends=('gtk3' 'gnutls' 'hardening-wrapper')
optdepends=('texlive-core: needed for dvipdf'
'gtk3: needed for gsx')
url="http://www.ghostscript.com/"
source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
- ghostscript-sys-zlib.patch)
+ ghostscript-sys-zlib.patch
+ bug_696246.diff
+ add_gserrors_h.diff
+ fix_check_for_using_shared_freetype_lib.diff)
#options=('!makeflags')
# http://downloads.ghostscript.com/public/SHA1SUMS
-sha1sums=('19f01538d33b9623bc6653d96ea4ec891f14a9d3'
- 'e054caf753df4d67221b29a2eac66130653f7556')
+sha1sums=('388fea50a38e422a4c6ff27c184491bf5ecb96e1'
+ 'e054caf753df4d67221b29a2eac66130653f7556'
+ 'f259eaac3beb0ec346bb2d4d2455e4e3baddecd4'
+ 'ca686fed1af36d1f9fa866b47ff129c71d6a19ff'
+ '8258043b111832fe52989ccb00d6d87285fcad81')
prepare() {
cd ghostscript-${pkgver}
# fix build with system zlib
patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
+ # fix http://bugs.ghostscript.com/show_bug.cgi?id=696246 - FS#46637, FS#46734?
+ patch -Np1 -i ${srcdir}/bug_696246.diff
+ # add a missing header; FS#46928
+ patch -Np1 -i ${srcdir}/add_gserrors_h.diff
+ # fix use system freetype - FS#46744
+ # http://git.ghostscript.com/?p=ghostpdl.git;a=patch;h=8f5d28536e4518716fdfe974e580194c8f57871d
+ patch -Np1 -i ${srcdir}/fix_check_for_using_shared_freetype_lib.diff
}
build() {