summaryrefslogtreecommitdiffstats
path: root/abs/core/ghostscript/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ghostscript/PKGBUILD')
-rw-r--r--abs/core/ghostscript/PKGBUILD67
1 files changed, 44 insertions, 23 deletions
diff --git a/abs/core/ghostscript/PKGBUILD b/abs/core/ghostscript/PKGBUILD
index a911598..f27e992 100644
--- a/abs/core/ghostscript/PKGBUILD
+++ b/abs/core/ghostscript/PKGBUILD
@@ -1,26 +1,42 @@
-# $Id: PKGBUILD 149988 2012-02-12 09:04:00Z andyrtr $
+# $Id$
# Maintainer: AndyRTR <andyrtr@archlinux.org>
+### !!! rebuild groff from core that picks up hardcoding the GS versioned font path !!! ###
+
pkgname=ghostscript
-pkgver=9.05
+pkgver=9.15
pkgrel=1
pkgdesc="An interpreter for the PostScript language"
arch=('i686' 'x86_64')
-license=('GPL3' 'custom')
-depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
-makedepends=('gtk2' 'gnutls')
+license=('AGPL' 'custom')
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
+ 'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
+makedepends=('gtk3' 'gnutls')
optdepends=('texlive-core: needed for dvipdf'
- 'gtk2: needed for gsx')
+ 'gtk3: needed for gsx')
url="http://www.ghostscript.com/"
-source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
-options=('!libtool' '!makeflags')
-md5sums=('8bcef1f33ddf8a4d12b2cf8da385c191')
+source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
+ ghostscript-sys-zlib.patch)
+#options=('!makeflags')
+# http://downloads.ghostscript.com/public/SHA1SUMS
+sha1sums=('19f01538d33b9623bc6653d96ea4ec891f14a9d3'
+ 'e054caf753df4d67221b29a2eac66130653f7556')
+
+prepare() {
+ cd ghostscript-${pkgver}
+ # fix build with system zlib
+ patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
+}
build() {
- cd ${srcdir}/ghostscript-${pkgver}
+ cd ghostscript-${pkgver}
# force it to use system-libs
- rm -rf jpeg libpng zlib jasper expat tiff lcms freetype
+ # keep heavily patched included openjpeg, leads to segfault with system openjpeg
+ # https://bugs.archlinux.org/task/38226
+ rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
+
+ autoconf --force
./configure --prefix=/usr \
--enable-dynamic \
@@ -30,37 +46,42 @@ build() {
--with-x \
--with-drivers=ALL\
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --with-install-cups \
--enable-fontconfig \
--enable-freetype \
+ --enable-openjpeg \
--without-luratech \
+ --without-omni \
--with-system-libtiff \
+ --with-libpaper \
--disable-compile-inits #--help # needed for linking with system-zlib
make
# Build IJS
- cd ${srcdir}/ghostscript-${pkgver}/ijs
+ cd ijs
+ sed -i "s:AM_PROG_CC_STDC:AC_PROG_CC:g" configure.ac
./autogen.sh
./configure --prefix=/usr --enable-shared --disable-static
make
}
package() {
- cd ${srcdir}/ghostscript-${pkgver}
- make DESTDIR=${pkgdir} \
- cups_serverroot=${pkgdir}/etc/cups \
- cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
+ cd ghostscript-${pkgver}
+ make DESTDIR="${pkgdir}" \
+ cups_serverroot="${pkgdir}"/etc/cups \
+ cups_serverbin="${pkgdir}"/usr/lib/cups install install-so
# install missing doc files # http://bugs.archlinux.org/task/18023
- install -m 644 ${srcdir}/ghostscript-${pkgver}/doc/{Ps2ps2.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} ${pkgdir}/usr/share/ghostscript/$pkgver/doc/
+ install -m 644 "${srcdir}"/ghostscript-${pkgver}/doc/{Ps2ps2.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} "${pkgdir}"/usr/share/ghostscript/$pkgver/doc/
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
# remove unwanted localized man-pages
- rm -rf $pkgdir/usr/share/man/[^man1]*
+ rm -rf "$pkgdir"/usr/share/man/[^man1]*
# install IJS
- cd ${srcdir}/ghostscript-${pkgver}/ijs
- make DESTDIR=${pkgdir} install
+ cd ijs
+ make DESTDIR="${pkgdir}" install
+
+ # remove filters that are now maintained in cups-filters as upstream home
+ rm -rf "$pkgdir"/usr/lib/cups/filter/{gstopxl,gstoraster}
}