summaryrefslogtreecommitdiffstats
path: root/abs/core/gobject-introspection/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gobject-introspection/PKGBUILD')
-rw-r--r--abs/core/gobject-introspection/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
new file mode 100644
index 0000000..179c5bf
--- /dev/null
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 81938 2010-06-07 11:01:46Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+pkgname=gobject-introspection
+pkgver=0.6.14
+pkgrel=1
+pkgdesc="Introspection system for GObject-based libraries"
+url="http://live.gnome.org/GObjectInstrospection"
+arch=('x86_64' 'i686')
+license=('LGPL' 'GPL')
+depends=('libffi>=3.0.8' 'glib2>=2.24.1' 'python' 'cairo>=1.8.10')
+options=('!libtool')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/0.6/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c4713bcbcebb06861738a8f630ab05289666e631f42f7abbf2e836978db7eba6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}