summaryrefslogtreecommitdiffstats
path: root/abs/core/gtk2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gtk2/PKGBUILD')
-rw-r--r--abs/core/gtk2/PKGBUILD45
1 files changed, 17 insertions, 28 deletions
diff --git a/abs/core/gtk2/PKGBUILD b/abs/core/gtk2/PKGBUILD
index 4949bfc..81d2f0e 100644
--- a/abs/core/gtk2/PKGBUILD
+++ b/abs/core/gtk2/PKGBUILD
@@ -1,19 +1,23 @@
# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
-pkgbase=gtk2
-pkgname=('gtk2' 'gtk-update-icon-cache')
-pkgver=2.24.25
+pkgname=gtk2
+pkgver=2.24.29
pkgrel=1
-arch=('i686' 'x86_64')
+pkgdesc="GObject-based multi-platform GUI toolkit (legacy)"
+arch=(i686 x86_64)
url="http://www.gtk.org/"
-makedepends=('atk' 'pango' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage'
- 'shared-mime-info' 'cairo' 'libcups' 'gdk-pixbuf2' 'gobject-introspection' 'python2')
-license=('LGPL')
-source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-$pkgver.tar.xz
+depends=(atk pango libxcursor libxinerama libxrandr libxi libxcomposite libxdamage
+ shared-mime-info cairo libcups gtk-update-icon-cache librsvg)
+makedepends=(gobject-introspection python2)
+optdepends=('gnome-themes-standard: Default widget theme'
+ 'adwaita-icon-theme: Default icon theme')
+license=(LGPL)
+install=gtk2.install
+source=(https://download.gnome.org/sources/gtk+/2.24/gtk+-$pkgver.tar.xz
gtkrc xid-collision-debug.patch)
-sha256sums=('38af1020cb8ff3d10dda2c8807f11e92af9d2fa4045de61c62eedb7fbc7ea5b3'
- 'b77a427df55a14182c10ad7e683b4d662df2846fcd38df2aa8918159d6be3ae2'
+sha256sums=('0741c59600d3d810a223866453dc2bbb18ce4723828681ba24aa6519c37631b8'
+ 'bc968e3e4f57e818430130338e5f85a5025e21d7e31a3293b8f5a0e58362b805'
'd758bb93e59df15a4ea7732cf984d1c3c19dff67c94b957575efea132b8fe558')
prepare() {
@@ -35,15 +39,7 @@ build() {
make
}
-package_gtk2() {
- pkgdesc="GTK+ is a multi-platform toolkit (v2)"
- install=gtk2.install
- depends=('atk' 'pango' 'libxcursor' 'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage'
- 'shared-mime-info' 'cairo' 'libcups' 'gtk-update-icon-cache')
- optdepends=('gnome-themes-standard: Default widget theme'
- 'gnome-icon-theme: Default icon theme')
- replaces=('gtk2-docs')
-
+package() {
cd gtk+-$pkgver
make DESTDIR="$pkgdir" install
@@ -51,14 +47,7 @@ package_gtk2() {
install -Dm644 "$srcdir/gtkrc" "$pkgdir/usr/share/gtk-2.0/gtkrc"
- #split this out to use with gtk3 too
- rm $pkgdir/usr/bin/gtk-update-icon-cache
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
}
-package_gtk-update-icon-cache() {
- pkgdesc="The GTK+ update icon cache tool"
- depends=('gdk-pixbuf2>=2.24.1-3' 'hicolor-icon-theme')
- install=gtk-update-icon-cache.install
- cd gtk+-$pkgver/gtk
- install -D -m755 gtk-update-icon-cache "$pkgdir/usr/bin/gtk-update-icon-cache"
-}
+# vim:set noet sw=4: