summaryrefslogtreecommitdiffstats
path: root/abs/core/hwids
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/hwids')
-rw-r--r--abs/core/hwids/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/abs/core/hwids/PKGBUILD b/abs/core/hwids/PKGBUILD
index ea682a7..c900b05 100644
--- a/abs/core/hwids/PKGBUILD
+++ b/abs/core/hwids/PKGBUILD
@@ -1,17 +1,20 @@
-# $Id: PKGBUILD 163600 2012-07-16 16:55:13Z tomegun $
+# $Id$
# Maintainer: Tom Gundersen <teg@jklm.no>
pkgname=hwids
-pkgver=20120711
+pkgver=20161103
pkgrel=1
pkgdesc="hardware identification databases"
+makedepends=('git')
url=https://github.com/gentoo/hwids
license=('GPL2')
arch=('any')
-source=("https://github.com/gentoo/${pkgname}/tarball/${pkgname}-${pkgver}")
+source=("git://github.com/gentoo/hwids.git#tag=${pkgname}-${pkgver}")
package() {
- cd ${srcdir}/*
- mkdir -p "${pkgdir}/usr/share/hwdata"
- cp pci.ids usb.ids "${pkgdir}/usr/share/hwdata/"
+ cd hwids
+
+ for ids in pci.ids usb.ids; do
+ install -Dm644 "$ids" "${pkgdir}/usr/share/hwdata/${ids}"
+ done
}
-md5sums=('f28b77e9793330ed1cd3568a8f715237')
+md5sums=('SKIP')