summaryrefslogtreecommitdiffstats
path: root/abs/core/imagemagick/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/imagemagick/PKGBUILD')
-rw-r--r--abs/core/imagemagick/PKGBUILD190
1 files changed, 121 insertions, 69 deletions
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index 4080a3b..fea39d9 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -2,89 +2,141 @@
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgbase=imagemagick
-pkgname=('imagemagick' 'imagemagick-doc')
-pkgver=6.9.0.0
+pkgname=(libmagick imagemagick imagemagick-doc)
+pkgver=7.0.7.37
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.imagemagick.org/"
-license=('custom')
-makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
- 'openexr' 'libwmf' 'librsvg' 'libxml2' 'liblqr' 'openjpeg2'
- 'opencl-headers' 'libcl' 'libwebp' 'subversion')
-#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
-source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
- perlmagick.rpath.patch)
-sha1sums=('6bf4263ceaeea61e00fe15a95db320d49bcc48c4'
- 'SKIP'
- 'e143cf9d530fabf3b58023899b5cc544ba93daec')
+pkgdesc="An image viewing/manipulation program"
+url="https://www.imagemagick.org/"
+arch=(x86_64)
+license=(custom)
+depends=(libltdl lcms2 fontconfig libxext liblqr libraqm libpng libxml2)
+makedepends=(ghostscript openexr libwmf librsvg libxml2 openjpeg2 libraw opencl-headers libwebp
+ chrpath ocl-icd glu ghostpcl ghostxps)
+checkdepends=(gsfonts ttf-dejavu)
+_relname=ImageMagick-${pkgver%%.*}
+_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
+source=(https://www.imagemagick.org/download/$_tarname.tar.xz{,.asc}
+ arch-fonts.diff)
+sha256sums=('c722c6de497991023661e6a2e7605f3c6590a9989a170bdf2661328381a67165'
+ 'SKIP'
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
+
+shopt -s extglob
prepare() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- sed '/AC_PATH_XTRA/d' -i configure.ac
- autoreconf --force --install
- patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
+ mkdir -p binpkg/usr/lib/pkgconfig {binpkg,docpkg}/usr/share
+
+ cd $_tarname
+
+ # Fix up typemaps to match our packages, where possible
+ patch -Np1 -i ../arch-fonts.diff
+
+ # Don't run auto(re)conf; assumes use of git
}
build() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- [[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
- [[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"
-
- ./configure --prefix=/usr --sysconfdir=/etc --with-modules \
- --enable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 \
- --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
- --enable-opencl --with-openjp2 --without-gvc --without-djvu --without-autotrace \
- --without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
+ cd $_tarname
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-dejavu-font-dir=/usr/share/fonts/TTF \
+ --with-gs-font-dir=/usr/share/fonts/gsfonts \
+ PSDelegate=/usr/bin/gs \
+ XPSDelegate=/usr/bin/gxps \
+ PCLDelegate=/usr/bin/gpcl6 \
+ --enable-hdri \
+ --enable-opencl \
+ --with-gslib \
+ --with-lqr \
+ --with-modules \
+ --with-openexr \
+ --with-openjp2 \
+ --with-perl \
+ --with-perl-options=INSTALLDIRS=vendor \
+ --with-rsvg \
+ --with-webp \
+ --with-wmf \
+ --with-xml \
+ --without-autotrace \
+ --without-djvu \
+ --without-dps \
+ --without-fftw \
+ --without-fpx \
+ --without-gcc-arch \
+ --without-gvc \
+ --without-jbig
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
-check() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
-# make check
+check() (
+ cd $_tarname
+ ulimit -n 4096
+ make check
+)
+
+package_libmagick() {
+ pkgdesc+=" (library)"
+ optdepends=('ghostscript: PS/PDF support'
+ 'libraw: DNG support'
+ 'librsvg: SVG support'
+ 'libwebp: WEBP support'
+ 'libwmf: WMF support'
+ 'libxml2: Magick Scripting Language'
+ 'ocl-icd: OpenCL support'
+ 'openexr: OpenEXR support'
+ 'openjpeg2: JPEG2000 support'
+ 'pango: Text rendering')
+ backup=(etc/$_relname/{coder,colors,delegates,log,magic,mime,policy,quantization-table,thresholds,type,type-{dejavu,ghostscript}}.xml)
+ options=('!emptydirs' libtool)
+
+ cd $_tarname
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/etc/$_relname/type-{apple,urw-base35,windows}.xml
+ rm "$pkgdir"/usr/lib/*.la
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
+
+# Split 'imagemagick'
+ cd ../binpkg
+ mv "$pkgdir/usr/bin" usr/
+ mv "$pkgdir/usr/lib/perl5" usr/lib/
+ mv "$pkgdir/usr/share/man" usr/share/
+
+# Split docs
+ mv "$pkgdir/usr/share/doc" "$srcdir/docpkg/usr/share/"
}
package_imagemagick() {
- pkgdesc="An image viewing/manipulation program"
- depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr' 'libcl')
- optdepends=('imagemagick-doc: for additional information'
- 'ghostscript: for Ghostscript support'
- 'openexr: for OpenEXR support'
- 'openjpeg2: for JP2 support'
- 'libwmf: for WMF support'
- 'librsvg: for SVG support'
- 'libxml2: for XML support'
- 'libpng: for PNG support'
- 'libwebp: for WEBP support')
- backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
- "etc/ImageMagick-${pkgver%%.*}/colors.xml"
- "etc/ImageMagick-${pkgver%%.*}/delegates.xml"
- "etc/ImageMagick-${pkgver%%.*}/log.xml"
- "etc/ImageMagick-${pkgver%%.*}/magic.xml"
- "etc/ImageMagick-${pkgver%%.*}/mime.xml"
- "etc/ImageMagick-${pkgver%%.*}/policy.xml"
- "etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
- "etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
- "etc/ImageMagick-${pkgver%%.*}/type.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
- options=('!docs' 'libtool' '!emptydirs')
-
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- make -j1 DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
- install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
-
-#Cleaning
- rm -f "${pkgdir}"/usr/lib/*.la
+ depends=("libmagick=$pkgver-$pkgrel")
+ optdepends=('imagemagick-doc: manual and API docs')
+ options=('!emptydirs')
+
+ mv binpkg/* "$pkgdir"
+
+ find "$pkgdir/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
+
+# template start; name=perl-binary-module-dependency; version=1;
+#if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+# _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+# _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+# echo $_perlver_min $_perlver_max
+# depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+#fi
+# template end;
+
+ cd $_tarname
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
}
package_imagemagick-doc() {
- pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
+ pkgdesc+=" (manual and API docs)"
+ depends=()
+
+ mv docpkg/* "$pkgdir"
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- make DESTDIR="${pkgdir}" install-data-html
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
- install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
+ cd $_tarname
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
}