summaryrefslogtreecommitdiffstats
path: root/abs/core/intltool/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/intltool/PKGBUILD')
-rw-r--r--abs/core/intltool/PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/abs/core/intltool/PKGBUILD b/abs/core/intltool/PKGBUILD
index 3ddeaaf..36e18b7 100644
--- a/abs/core/intltool/PKGBUILD
+++ b/abs/core/intltool/PKGBUILD
@@ -1,19 +1,31 @@
-# $Id$
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=intltool
pkgver=0.51.0
-pkgrel=1
+pkgrel=4
pkgdesc="The internationalization tool collection"
arch=('any')
-url="https://edge.launchpad.net/intltool"
+url="https://launchpad.net/intltool"
license=('GPL')
depends=('perl-xml-parser')
-source=(http://launchpad.net/intltool/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz{,.asc})
-sha1sums=('a0c3bcb99d1bcfc5db70f8d848232a47c47da090'
- 'SKIP')
+source=(https://launchpad.net/intltool/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz{,.asc}
+ intltool-0.51.0-perl-5.26.patch
+ intltool-merge-Create-cache-file-atomically.patch
+ intltool_distcheck-fix.patch)
+sha256sums=('67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd'
+ 'SKIP'
+ '458f5d53ac358810879080f69b11649901babcacc14471c243eb850e9436d546'
+ '13bd6deb65dc94933f132919d4eea4c24354d7c1c1c9e5930cb6e70c75703763'
+ '58cb7d60796bc69c7d0865f106feb589d0271619e62f8741bff6f5ce1a2615ff')
validpgpkeys=('9EBD001680E8C8F9FAC61A9BE1A701D4C9DE75B5')
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i ../intltool-0.51.0-perl-5.26.patch
+ patch -Np1 -i ../intltool-merge-Create-cache-file-atomically.patch
+ patch -Np1 -i ../intltool_distcheck-fix.patch
+}
+
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr