summaryrefslogtreecommitdiffstats
path: root/abs/core/klibc-module-init-tools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/klibc-module-init-tools/PKGBUILD')
-rw-r--r--abs/core/klibc-module-init-tools/PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/abs/core/klibc-module-init-tools/PKGBUILD b/abs/core/klibc-module-init-tools/PKGBUILD
index 80a1ede..a7d6884 100644
--- a/abs/core/klibc-module-init-tools/PKGBUILD
+++ b/abs/core/klibc-module-init-tools/PKGBUILD
@@ -1,29 +1,23 @@
-# $Id: PKGBUILD 5989 2008-07-22 12:58:46Z thomas $
+# $Id: PKGBUILD 23617 2009-01-11 14:11:13Z thomas $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgname=klibc-module-init-tools
-pkgver=3.4
-pkgrel=10
+pkgver=3.5
+pkgrel=30
pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
arch=(i686 x86_64)
url="http://www.kernel.org"
license=('GPL')
groups=('base')
depends=('klibc' $(basename /lib/klibc-*.so .so))
-source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2 \
- makefile.patch
- fix-modprobe-ignore-path.patch)
-md5sums=('db6ac059e80e8dd4389dbe81ee61f3c6'
- 'c48553c2b61fd8d9784aa86e559b9d7b'
- '335c3f8317f257ddd70b09271b4360bd')
+source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2)
+md5sums=('2b47686247fc9a99bfdb9dd1d1d80e6f')
build() {
cd $startdir/src/module-init-tools-$pkgver
- patch -p1 -i ../makefile.patch || return 1
- autoreconf || return 1
- patch -p0 -i ../fix-modprobe-ignore-path.patch || return 1
- sed -i 's|/usr/bin/install|/bin/install|g' install-with-care
CFLAGS="${CFLAGS} -DCONFIG_NO_BACKWARDS_COMPAT" CC=klcc LD=klcc ./configure --prefix=/usr/lib/klibc
+ # klibc lacks getc_unlocked, so use getc instead
+ sed 's|getc_unlocked|getc|g' -i *.c
make || return 1
INSTALL=/bin/install make DESTDIR=$startdir/pkg install || return 1
rm -f $startdir/pkg/usr/lib/klibc/sbin/{generate-modprobe.conf,insmod.static}