summaryrefslogtreecommitdiffstats
path: root/abs/core/klibc
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/klibc')
-rw-r--r--abs/core/klibc/PKGBUILD48
-rw-r--r--abs/core/klibc/klibc-Kbuild.patch73
-rw-r--r--abs/core/klibc/klibc-fix-2.6.28-includes.patch12
-rw-r--r--abs/core/klibc/klibc-x86_64-fix-io.h.patch28
4 files changed, 117 insertions, 44 deletions
diff --git a/abs/core/klibc/PKGBUILD b/abs/core/klibc/PKGBUILD
index a65d119..11080c0 100644
--- a/abs/core/klibc/PKGBUILD
+++ b/abs/core/klibc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 5849 2008-07-21 18:46:34Z thomas $
+# $Id: PKGBUILD 23627 2009-01-11 14:22:23Z thomas $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
@@ -9,28 +9,26 @@
###
pkgname=klibc
-pkgver=1.5
-_klibcbranch=Stable #Stable/Testing
-_kver=2.6.26-ARCH
-pkgrel=15
+pkgver=1.5.15
+_klibcbranch=Testing #Stable/Testing
+_kver=2.6.28-ARCH
+pkgrel=30
pkgdesc="A minimal libc made for early-userspace"
arch=(i686 x86_64)
url="http://www.kernel.org/pub/linux/libs/klibc/"
license=('BSD')
groups=('base')
options=(!ccache !strip)
-source=(http://www.kernel.org/pub/linux/libs/klibc/$_klibcbranch/$pkgname-$pkgver.tar.gz
- multiple_raid_assembly_fix.patch
+source=(http://www.kernel.org/pub/linux/libs/klibc/${_klibcbranch}/${pkgname}-${pkgver}.tar.gz
klibc-compile-shared-by-default.patch
- klibc-module-init-tools.patch
- klibc-2.6.24.patch
- klibc-Kbuild.patch)
-md5sums=('d55ce89c0656a7d6896ec0b2af07b5dc'
- '8d257d50a4554d57b8f461c6a87a2877'
+ klibc-Kbuild.patch
+ klibc-x86_64-fix-io.h.patch
+ klibc-fix-2.6.28-includes.patch)
+md5sums=('b5527be46f24779884557b11888c8075'
'c263a7c3fd290fcc84a4e230d456d022'
- '4d78311ebce63f2fbb711f8518e71839'
- 'a98b3e96aff53339572ed0bdccc8aed2'
- 'c928be0153585a487b72a7eb5dfa8b13')
+ 'ff5b113024256de31af59c2f1a966516'
+ 'fcee75cfaa65638b07f9cc4a7719fa29'
+ '85e39751debc304119eb481d6bc26d59')
build()
{
@@ -39,23 +37,19 @@ build()
sed -i "/#define INI_DEBUG/d" usr/kinit/kinit.h || return 1
ln -sf /usr/src/linux-${_kver} linux
- patch -p1 -i ../multiple_raid_assembly_fix.patch || return 1
- # make klibc-module-init-tools compile
- # don't build insmod
- patch -p1 -i ../klibc-module-init-tools.patch || return 1
# compile binaries shared by default
patch -p1 -i ../klibc-compile-shared-by-default.patch || return 1
- # fix compilation on 2.6.24
- patch -p1 -i ../klibc-2.6.24.patch || return 1
- # don't build kill, gzip and cpio
- patch -p1 -i ../klibc-Kbuild.patch || return 1
+ # don't build gzip, cpio, kill, build shared binaries for kinit and sh
+ patch -p1 -i ../klibc-Kbuild.patch || return 1
+ # fix errors in io.h header
+ patch -p1 -i ../klibc-x86_64-fix-io.h.patch || return 1
+ # fix includes for 2.6.28 build
+ patch -p1 -i ../klibc-fix-2.6.28-includes.patch || return 1
make EXTRA_KLIBCFLAGS='' || return 1
make INSTALLROOT=$startdir/pkg install || return 1
- #simplify
- mv $startdir/pkg/usr/lib/klibc/bin/sh.shared $startdir/pkg/usr/lib/klibc/bin/sh
- mv $startdir/pkg/usr/lib/klibc/bin/kinit.shared $startdir/pkg/usr/lib/klibc/bin/kinit
- ln -sf asm-x86 $startdir/pkg/usr/lib/klibc/include/asm
+ #ln -sf asm-x86 $startdir/pkg/usr/lib/klibc/include/asm
+ cp -a linux/arch/x86/include/asm/* $startdir/pkg/usr/lib/klibc/include/asm/
provides[${#provides[@]}]="$(basename $startdir/pkg/lib/klibc-*.so .so)"
export provides
diff --git a/abs/core/klibc/klibc-Kbuild.patch b/abs/core/klibc/klibc-Kbuild.patch
index 93a95da..28beee9 100644
--- a/abs/core/klibc/klibc-Kbuild.patch
+++ b/abs/core/klibc/klibc-Kbuild.patch
@@ -1,6 +1,6 @@
-diff -Nur klibc-1.5.orig/Kbuild klibc-1.5/Kbuild
---- klibc-1.5.orig/Kbuild 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/Kbuild 2008-05-14 12:45:02.000000000 +0200
+diff -Nur klibc-1.5.14.orig/Kbuild klibc-1.5.14/Kbuild
+--- klibc-1.5.14.orig/Kbuild 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/Kbuild 2008-09-18 13:08:42.000000000 +0200
@@ -10,9 +10,8 @@
$(Q)$(MAKE) $(klibc)=usr/kinit
$(Q)$(MAKE) $(klibc)=usr/dash
@@ -12,9 +12,9 @@ diff -Nur klibc-1.5.orig/Kbuild klibc-1.5/Kbuild
-subdir- := scripts/basic klcc usr/klibc usr/dash usr/utils usr/gzip \
+subdir- := scripts/basic klcc usr/klibc usr/dash usr/utils \
usr/kinit usr/klibc/tests
-diff -Nur klibc-1.5.orig/usr/Kbuild klibc-1.5/usr/Kbuild
---- klibc-1.5.orig/usr/Kbuild 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/Kbuild 2008-05-14 12:45:02.000000000 +0200
+diff -Nur klibc-1.5.14.orig/usr/Kbuild klibc-1.5.14/usr/Kbuild
+--- klibc-1.5.14.orig/usr/Kbuild 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/usr/Kbuild 2008-09-18 13:08:42.000000000 +0200
@@ -6,7 +6,7 @@
include-subdir := include
@@ -24,18 +24,57 @@ diff -Nur klibc-1.5.orig/usr/Kbuild klibc-1.5/usr/Kbuild
subdir- := $(include-subdir) $(klibc-subdir) $(usr-subdirs)
usr-subdirs := $(addprefix _usr_,$(usr-subdirs))
-diff -Nur klibc-1.5.orig/usr/utils/Kbuild klibc-1.5/usr/utils/Kbuild
---- klibc-1.5.orig/usr/utils/Kbuild 2008-05-14 12:44:47.000000000 +0200
-+++ klibc-1.5/usr/utils/Kbuild 2008-05-14 12:45:20.000000000 +0200
-@@ -2,9 +2,9 @@
- # Kbuild file for klib utils
- #
-
--progs := chroot dd mkdir mkfifo mknod mount pivot_root umount
-+progs := chroot dd mkdir mkfifo mount pivot_root umount
+diff -Nur klibc-1.5.14.orig/usr/dash/Kbuild klibc-1.5.14/usr/dash/Kbuild
+--- klibc-1.5.14.orig/usr/dash/Kbuild 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/usr/dash/Kbuild 2008-09-18 13:08:42.000000000 +0200
+@@ -23,11 +23,8 @@
+ hostprogs-y := mkinit mksyntax mknodes mksignames
+ gen-h-files := arith.h builtins.h nodes.h syntax.h token.h
+
+-static-y := sh
+-
+ # The shared binary
+-shared-y := sh.shared
+-sh.shared-y := $(sh-y)
++shared-y := sh
+
+ # For cleaning
+ targets := sh sh.g sh.shared sh.shared.g $(gen-o-files)
+@@ -108,4 +105,4 @@
+ $(Q):
+
+ # Targets to install
+-install-y := sh.shared
++install-y := sh
+diff -Nur klibc-1.5.14.orig/usr/kinit/Kbuild klibc-1.5.14/usr/kinit/Kbuild
+--- klibc-1.5.14.orig/usr/kinit/Kbuild 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/usr/kinit/Kbuild 2008-09-18 13:08:42.000000000 +0200
+@@ -17,9 +17,7 @@
+ kinit-y += fstype/
+ kinit-y += resume/
+
+-static-y := kinit
+-shared-y := kinit.shared
+-kinit.shared-y := $(kinit-y)
++shared-y := kinit
+
+ # Additional include paths files
+ KLIBCCFLAGS += -I$(srctree)/$(src)/fstype \
+@@ -34,4 +32,4 @@
+
+
+ # install binary
+-install-y := kinit kinit.shared
++install-y := kinit
+diff -Nur klibc-1.5.14.orig/usr/utils/Kbuild klibc-1.5.14/usr/utils/Kbuild
+--- klibc-1.5.14.orig/usr/utils/Kbuild 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/usr/utils/Kbuild 2008-09-18 13:08:56.000000000 +0200
+@@ -4,7 +4,7 @@
+
+ progs := chroot dd mkdir mkfifo mknod mount pivot_root umount
progs += true false sleep ln nuke minips cat
--progs += uname halt kill readlink cpio
-+progs += uname halt readlink
+-progs += uname halt kill readlink cpio sync dmesg
++progs += uname halt readlink sync dmesg
static-y := $(addprefix static/, $(progs))
shared-y := $(addprefix shared/, $(progs))
diff --git a/abs/core/klibc/klibc-fix-2.6.28-includes.patch b/abs/core/klibc/klibc-fix-2.6.28-includes.patch
new file mode 100644
index 0000000..d7108a4
--- /dev/null
+++ b/abs/core/klibc/klibc-fix-2.6.28-includes.patch
@@ -0,0 +1,12 @@
+diff -Nur klibc-1.5.14.orig/scripts/Kbuild.klibc klibc-1.5.14/scripts/Kbuild.klibc
+--- klibc-1.5.14.orig/scripts/Kbuild.klibc 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/scripts/Kbuild.klibc 2008-12-29 23:59:14.000000000 +0100
+@@ -103,7 +103,7 @@
+ -I$(KLIBCINC)
+ # kernel include paths
+ KLIBCKERNELSRC ?= $(srctree)/
+-KLIBCCPPFLAGS += -I$(KLIBCKERNELSRC)include \
++KLIBCCPPFLAGS += -I$(KLIBCKERNELSRC)include -I$(KLIBCKERNELSRC)arch/x86/include \
+ $(if $(KBUILD_SRC),-I$(KLIBCKERNELOBJ)include2 -I$(KLIBCKERNELOBJ)include -I$(srctree)/include) \
+ $(KLIBCARCHINCFLAGS)
+
diff --git a/abs/core/klibc/klibc-x86_64-fix-io.h.patch b/abs/core/klibc/klibc-x86_64-fix-io.h.patch
new file mode 100644
index 0000000..25ef789
--- /dev/null
+++ b/abs/core/klibc/klibc-x86_64-fix-io.h.patch
@@ -0,0 +1,28 @@
+diff -Nur klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h klibc-1.5.14/usr/include/arch/x86_64/sys/io.h
+--- klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h 2008-07-30 23:06:03.000000000 +0200
++++ klibc-1.5.14/usr/include/arch/x86_64/sys/io.h 2008-09-18 14:34:20.000000000 +0200
+@@ -60,21 +60,21 @@
+ {
+ unsigned char __v;
+ asm volatile ("inb %1,%0" : "=a" (__v) : "dN"(__p));
+- return v;
++ return __v;
+ }
+
+ static __inline__ unsigned short inw(unsigned short __p)
+ {
+ unsigned short __v;
+ asm volatile ("inw %1,%0" : "=a" (__v) : "dN"(__p));
+- return v;
++ return __v;
+ }
+
+ static __inline__ unsigned int inl(unsigned short __p)
+ {
+ unsigned int __v;
+ asm volatile ("inl %1,%0" : "=a" (__v) : "dN"(__p));
+- return v;
++ return __v;
+ }
+
+ /* String I/O macros */