summaryrefslogtreecommitdiffstats
path: root/abs/core/klibc
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/klibc')
-rw-r--r--abs/core/klibc/PKGBUILD56
-rw-r--r--abs/core/klibc/klibc-2.6.24.patch44
-rw-r--r--abs/core/klibc/klibc-Kbuild.patch80
-rw-r--r--abs/core/klibc/klibc-compile-shared-by-default.patch12
-rw-r--r--abs/core/klibc/klibc-fix-2.6.28-includes.patch12
-rw-r--r--abs/core/klibc/klibc-module-init-tools.patch63
-rw-r--r--abs/core/klibc/klibc-x86_64-fix-io.h.patch28
-rw-r--r--abs/core/klibc/multiple_raid_assembly_fix.patch20
8 files changed, 0 insertions, 315 deletions
diff --git a/abs/core/klibc/PKGBUILD b/abs/core/klibc/PKGBUILD
deleted file mode 100644
index 11080c0..0000000
--- a/abs/core/klibc/PKGBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# $Id: PKGBUILD 23627 2009-01-11 14:22:23Z thomas $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
-
-###
-### NOTE: Do not build this package with anything except gcc - using ccache
-### forces others to use it as well as it becomes hardcoded in the klibc
-### script.
-###
-
-pkgname=klibc
-pkgver=1.5.15
-_klibcbranch=Testing #Stable/Testing
-_kver=2.6.28-ARCH
-pkgrel=30
-pkgdesc="A minimal libc made for early-userspace"
-arch=(i686 x86_64)
-url="http://www.kernel.org/pub/linux/libs/klibc/"
-license=('BSD')
-groups=('base')
-options=(!ccache !strip)
-source=(http://www.kernel.org/pub/linux/libs/klibc/${_klibcbranch}/${pkgname}-${pkgver}.tar.gz
- klibc-compile-shared-by-default.patch
- klibc-Kbuild.patch
- klibc-x86_64-fix-io.h.patch
- klibc-fix-2.6.28-includes.patch)
-md5sums=('b5527be46f24779884557b11888c8075'
- 'c263a7c3fd290fcc84a4e230d456d022'
- 'ff5b113024256de31af59c2f1a966516'
- 'fcee75cfaa65638b07f9cc4a7719fa29'
- '85e39751debc304119eb481d6bc26d59')
-
-build()
-{
- cd $startdir/src/$pkgname-$pkgver
- #INI_DEBUG causes ipconfig to fail within kinit
- sed -i "/#define INI_DEBUG/d" usr/kinit/kinit.h || return 1
- ln -sf /usr/src/linux-${_kver} linux
-
- # compile binaries shared by default
- patch -p1 -i ../klibc-compile-shared-by-default.patch || return 1
- # don't build gzip, cpio, kill, build shared binaries for kinit and sh
- patch -p1 -i ../klibc-Kbuild.patch || return 1
- # fix errors in io.h header
- patch -p1 -i ../klibc-x86_64-fix-io.h.patch || return 1
- # fix includes for 2.6.28 build
- patch -p1 -i ../klibc-fix-2.6.28-includes.patch || return 1
-
- make EXTRA_KLIBCFLAGS='' || return 1
- make INSTALLROOT=$startdir/pkg install || return 1
- #ln -sf asm-x86 $startdir/pkg/usr/lib/klibc/include/asm
- cp -a linux/arch/x86/include/asm/* $startdir/pkg/usr/lib/klibc/include/asm/
-
- provides[${#provides[@]}]="$(basename $startdir/pkg/lib/klibc-*.so .so)"
- export provides
-}
diff --git a/abs/core/klibc/klibc-2.6.24.patch b/abs/core/klibc/klibc-2.6.24.patch
deleted file mode 100644
index 2527699..0000000
--- a/abs/core/klibc/klibc-2.6.24.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-unchanged:
---- klibc-1.5.orig/usr/klibc/arch/i386/MCONFIG 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/klibc/arch/i386/MCONFIG 2008-01-27 16:06:08.000000000 +0100
-@@ -31,3 +31,4 @@
- # calls, and work on the memory models for this architecture
- # 96 MB - normal binaries start at 128 MB
- KLIBCSHAREDFLAGS = -Ttext 0x06000200
-+KLIBCASMARCH = x86
-unchanged:
---- klibc-1.5.orig/usr/klibc/arch/x86_64/MCONFIG 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/klibc/arch/x86_64/MCONFIG 2008-01-27 16:05:43.000000000 +0100
-@@ -36,4 +36,4 @@
- KLIBCSHAREDFLAGS = -Ttext 0x00200200 -z max-page-size=0x100000
-
- # Additional asm- directories needed during installation
--ASMARCH = asm-i386
-+KLIBCASMARCH = x86
-only in patch2:
-unchanged:
---- a/scripts/Kbuild.install 2007-03-04 02:52:10.000000000 +0100
-+++ b/scripts/Kbuild.install 2007-11-04 15:43:28.000000000 +0100
-@@ -84,6 +84,13 @@
- # 1) Create directories, install headers and man pages
- # 2) Tell that we now install binaries
- # 3) Install binaries by descending
-+
-+# Arch specific definitions for klibc
-+include $(KLIBCSRC)/arch/$(KLIBCARCHDIR)/MCONFIG
-+
-+# include/asm-* architecture
-+KLIBCASMARCH ?= $(KLIBCARCH)
-+
- .PHONY: header footer descend
- header:
- $(Q)echo " INSTALL headers + man pages to $(INSTALLROOT)$(INSTALLDIR)"
-@@ -95,7 +102,7 @@
- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)lib
- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)bin
-- $(Q)set -e ; for d in linux scsi asm-$(KLIBCARCH) asm-generic $(ASMKLIBCARCH); do \
-+ $(Q)set -e ; for d in linux scsi asm-$(KLIBCASMARCH) asm-generic $(ASMKLIBCARCH); do \
- mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KLIBCCROSS)include/$$d ; \
- for r in $(KLIBCKERNELSRC)/include $(KLIBCKERNELOBJ)/include \
- $(KLIBCKERNELOBJ)/include2 ; do \
diff --git a/abs/core/klibc/klibc-Kbuild.patch b/abs/core/klibc/klibc-Kbuild.patch
deleted file mode 100644
index 28beee9..0000000
--- a/abs/core/klibc/klibc-Kbuild.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -Nur klibc-1.5.14.orig/Kbuild klibc-1.5.14/Kbuild
---- klibc-1.5.14.orig/Kbuild 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/Kbuild 2008-09-18 13:08:42.000000000 +0200
-@@ -10,9 +10,8 @@
- $(Q)$(MAKE) $(klibc)=usr/kinit
- $(Q)$(MAKE) $(klibc)=usr/dash
- $(Q)$(MAKE) $(klibc)=usr/utils
-- $(Q)$(MAKE) $(klibc)=usr/gzip
-
-
- # Directories to visit during clean and install
--subdir- := scripts/basic klcc usr/klibc usr/dash usr/utils usr/gzip \
-+subdir- := scripts/basic klcc usr/klibc usr/dash usr/utils \
- usr/kinit usr/klibc/tests
-diff -Nur klibc-1.5.14.orig/usr/Kbuild klibc-1.5.14/usr/Kbuild
---- klibc-1.5.14.orig/usr/Kbuild 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/Kbuild 2008-09-18 13:08:42.000000000 +0200
-@@ -6,7 +6,7 @@
-
- include-subdir := include
- klibc-subdir := klibc
--usr-subdirs := kinit utils dash gzip
-+usr-subdirs := kinit utils dash
- subdir- := $(include-subdir) $(klibc-subdir) $(usr-subdirs)
-
- usr-subdirs := $(addprefix _usr_,$(usr-subdirs))
-diff -Nur klibc-1.5.14.orig/usr/dash/Kbuild klibc-1.5.14/usr/dash/Kbuild
---- klibc-1.5.14.orig/usr/dash/Kbuild 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/dash/Kbuild 2008-09-18 13:08:42.000000000 +0200
-@@ -23,11 +23,8 @@
- hostprogs-y := mkinit mksyntax mknodes mksignames
- gen-h-files := arith.h builtins.h nodes.h syntax.h token.h
-
--static-y := sh
--
- # The shared binary
--shared-y := sh.shared
--sh.shared-y := $(sh-y)
-+shared-y := sh
-
- # For cleaning
- targets := sh sh.g sh.shared sh.shared.g $(gen-o-files)
-@@ -108,4 +105,4 @@
- $(Q):
-
- # Targets to install
--install-y := sh.shared
-+install-y := sh
-diff -Nur klibc-1.5.14.orig/usr/kinit/Kbuild klibc-1.5.14/usr/kinit/Kbuild
---- klibc-1.5.14.orig/usr/kinit/Kbuild 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/kinit/Kbuild 2008-09-18 13:08:42.000000000 +0200
-@@ -17,9 +17,7 @@
- kinit-y += fstype/
- kinit-y += resume/
-
--static-y := kinit
--shared-y := kinit.shared
--kinit.shared-y := $(kinit-y)
-+shared-y := kinit
-
- # Additional include paths files
- KLIBCCFLAGS += -I$(srctree)/$(src)/fstype \
-@@ -34,4 +32,4 @@
-
-
- # install binary
--install-y := kinit kinit.shared
-+install-y := kinit
-diff -Nur klibc-1.5.14.orig/usr/utils/Kbuild klibc-1.5.14/usr/utils/Kbuild
---- klibc-1.5.14.orig/usr/utils/Kbuild 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/utils/Kbuild 2008-09-18 13:08:56.000000000 +0200
-@@ -4,7 +4,7 @@
-
- progs := chroot dd mkdir mkfifo mknod mount pivot_root umount
- progs += true false sleep ln nuke minips cat
--progs += uname halt kill readlink cpio sync dmesg
-+progs += uname halt readlink sync dmesg
-
- static-y := $(addprefix static/, $(progs))
- shared-y := $(addprefix shared/, $(progs))
diff --git a/abs/core/klibc/klibc-compile-shared-by-default.patch b/abs/core/klibc/klibc-compile-shared-by-default.patch
deleted file mode 100644
index e144c3e..0000000
--- a/abs/core/klibc/klibc-compile-shared-by-default.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur klibc-1.5.orig/klcc/klcc.in klibc-1.5/klcc/klcc.in
---- klibc-1.5.orig/klcc/klcc.in 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/klcc/klcc.in 2007-10-31 09:20:34.000000000 +0100
-@@ -113,7 +113,7 @@
-
- $save_temps = 0; # The -save-temps option
- $verbose = 0; # The -v option
--$shared = 0; # Are we compiling shared?
-+$shared = 1; # Are we compiling shared?
- $debugging = 0; # -g or -p option present?
- $strip = 0; # -s option present?
- undef $output; # -o option present?
diff --git a/abs/core/klibc/klibc-fix-2.6.28-includes.patch b/abs/core/klibc/klibc-fix-2.6.28-includes.patch
deleted file mode 100644
index d7108a4..0000000
--- a/abs/core/klibc/klibc-fix-2.6.28-includes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur klibc-1.5.14.orig/scripts/Kbuild.klibc klibc-1.5.14/scripts/Kbuild.klibc
---- klibc-1.5.14.orig/scripts/Kbuild.klibc 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/scripts/Kbuild.klibc 2008-12-29 23:59:14.000000000 +0100
-@@ -103,7 +103,7 @@
- -I$(KLIBCINC)
- # kernel include paths
- KLIBCKERNELSRC ?= $(srctree)/
--KLIBCCPPFLAGS += -I$(KLIBCKERNELSRC)include \
-+KLIBCCPPFLAGS += -I$(KLIBCKERNELSRC)include -I$(KLIBCKERNELSRC)arch/x86/include \
- $(if $(KBUILD_SRC),-I$(KLIBCKERNELOBJ)include2 -I$(KLIBCKERNELOBJ)include -I$(srctree)/include) \
- $(KLIBCARCHINCFLAGS)
-
diff --git a/abs/core/klibc/klibc-module-init-tools.patch b/abs/core/klibc/klibc-module-init-tools.patch
deleted file mode 100644
index a5e4532..0000000
--- a/abs/core/klibc/klibc-module-init-tools.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -Nur klibc-1.5.orig/usr/include/sys/elf32.h klibc-1.5/usr/include/sys/elf32.h
---- klibc-1.5.orig/usr/include/sys/elf32.h 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/include/sys/elf32.h 2007-10-31 09:18:09.000000000 +0100
-@@ -110,4 +110,8 @@
- Elf32_Word n_type; /* Content type */
- } Elf32_Nhdr;
-
-+/* How to extract and insert information held in the st_info field. */
-+#define ELF32_ST_BIND(val) (((unsigned char) (val)) >> 4)
-+#define ELF32_ST_TYPE(val) ((val) & 0xf)
-+
- #endif /* _SYS_ELF32_H */
-diff -Nur klibc-1.5.orig/usr/include/sys/elf64.h klibc-1.5/usr/include/sys/elf64.h
---- klibc-1.5.orig/usr/include/sys/elf64.h 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/include/sys/elf64.h 2007-10-31 09:18:09.000000000 +0100
-@@ -110,4 +110,8 @@
- Elf64_Word n_type; /* Content type */
- } Elf64_Nhdr;
-
-+/* Both Elf32_Sym and Elf64_Sym use the same one-byte st_info field. */
-+#define ELF64_ST_BIND(val) ELF32_ST_BIND (val)
-+#define ELF64_ST_TYPE(val) ELF32_ST_TYPE (val)
-+
- #endif /* _SYS_ELF64_H */
-diff -Nur klibc-1.5.orig/usr/include/sys/elfcommon.h klibc-1.5/usr/include/sys/elfcommon.h
---- klibc-1.5.orig/usr/include/sys/elfcommon.h 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/include/sys/elfcommon.h 2007-10-31 09:18:09.000000000 +0100
-@@ -184,4 +184,14 @@
- #define ELFOSABI_NONE 0
- #define ELFOSABI_LINUX 3
-
-+/* Legal values for ST_BIND subfield of st_info (symbol binding). */
-+#define STB_LOCAL 0 /* Local symbol */
-+#define STB_GLOBAL 1 /* Global symbol */
-+#define STB_WEAK 2 /* Weak symbol */
-+#define STB_NUM 3 /* Number of defined types. */
-+#define STB_LOOS 10 /* Start of OS-specific */
-+#define STB_HIOS 12 /* End of OS-specific */
-+#define STB_LOPROC 13 /* Start of processor-specific */
-+#define STB_HIPROC 15 /* End of processor-specific */
-+
- #endif /* _SYS_ELFCOMMON_H */
-diff -Nur klibc-1.5.orig/usr/utils/Kbuild klibc-1.5/usr/utils/Kbuild
---- klibc-1.5.orig/usr/utils/Kbuild 2007-03-04 02:52:10.000000000 +0100
-+++ klibc-1.5/usr/utils/Kbuild 2007-10-31 09:18:28.000000000 +0100
-@@ -4,7 +4,7 @@
-
- progs := chroot dd mkdir mkfifo mknod mount pivot_root umount
- progs += true false sleep ln nuke minips cat
--progs += insmod uname halt kill readlink cpio
-+progs += uname halt kill readlink cpio
-
- static-y := $(addprefix static/, $(progs))
- shared-y := $(addprefix shared/, $(progs))
-@@ -40,8 +40,6 @@
- shared/minips-y := minips.o
- static/cat-y := cat.o
- shared/cat-y := cat.o
--static/insmod-y := insmod.o
--shared/insmod-y := insmod.o
- static/uname-y := uname.o
- shared/uname-y := uname.o
- static/halt-y := halt.o
diff --git a/abs/core/klibc/klibc-x86_64-fix-io.h.patch b/abs/core/klibc/klibc-x86_64-fix-io.h.patch
deleted file mode 100644
index 25ef789..0000000
--- a/abs/core/klibc/klibc-x86_64-fix-io.h.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -Nur klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h klibc-1.5.14/usr/include/arch/x86_64/sys/io.h
---- klibc-1.5.14.orig/usr/include/arch/x86_64/sys/io.h 2008-07-30 23:06:03.000000000 +0200
-+++ klibc-1.5.14/usr/include/arch/x86_64/sys/io.h 2008-09-18 14:34:20.000000000 +0200
-@@ -60,21 +60,21 @@
- {
- unsigned char __v;
- asm volatile ("inb %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- static __inline__ unsigned short inw(unsigned short __p)
- {
- unsigned short __v;
- asm volatile ("inw %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- static __inline__ unsigned int inl(unsigned short __p)
- {
- unsigned int __v;
- asm volatile ("inl %1,%0" : "=a" (__v) : "dN"(__p));
-- return v;
-+ return __v;
- }
-
- /* String I/O macros */
diff --git a/abs/core/klibc/multiple_raid_assembly_fix.patch b/abs/core/klibc/multiple_raid_assembly_fix.patch
deleted file mode 100644
index 237a1db..0000000
--- a/abs/core/klibc/multiple_raid_assembly_fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/usr/kinit/do_mounts_md.c 2006-07-31 21:16:01.000000000 -0500
-+++ b/usr/kinit/do_mounts_md.c 2006-07-31 21:18:46.000000000 -0500
-@@ -228,6 +228,7 @@
- char *devname;
- mdu_disk_info_t dinfo;
- char name[16];
-+ struct stat st_chk;
-
- dev_minor = md_setup_args[ent].minor;
- partitioned = md_setup_args[ent].partitioned;
-@@ -236,6 +237,9 @@
- snprintf(name, sizeof name,
- "/dev/md%s%d", partitioned ? "_d" : "", dev_minor);
-
-+ if (stat(name, &st_chk) == 0)
-+ continue;
-+
- if (partitioned)
- dev = makedev(mdp_major(), dev_minor << MdpMinorShift);
- else