summaryrefslogtreecommitdiffstats
path: root/abs/core/lame/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/lame/PKGBUILD')
-rw-r--r--abs/core/lame/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/abs/core/lame/PKGBUILD b/abs/core/lame/PKGBUILD
index 6853b74..432a519 100644
--- a/abs/core/lame/PKGBUILD
+++ b/abs/core/lame/PKGBUILD
@@ -1,26 +1,33 @@
-# $Id: PKGBUILD 80636 2010-05-20 16:06:46Z ibiru $
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# $Id$
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgname=lame
-pkgver=3.98.4
-pkgrel=1
-pkgdesc="An MP3 encoder and graphical frame analyzer"
+pkgver=3.99.5
+pkgrel=2
+pkgdesc="A high quality MPEG Audio Layer III (MP3) encoder"
arch=('i686' 'x86_64')
url="http://lame.sourceforge.net/"
depends=('ncurses')
makedepends=('nasm')
license=('LGPL')
-options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('8e9866ad6b570c6c95c8cba48060473f')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('84835b313d4a8b68f5349816d33e07ce')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
--enable-nasm \
--enable-shared
- make -j1 || return 1
- make DESTDIR="${pkgdir}" install || return 1
+ make
}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: