summaryrefslogtreecommitdiffstats
path: root/abs/core/ldns/pc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/ldns/pc.patch')
-rw-r--r--abs/core/ldns/pc.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/abs/core/ldns/pc.patch b/abs/core/ldns/pc.patch
new file mode 100644
index 0000000..a37b1c3
--- /dev/null
+++ b/abs/core/ldns/pc.patch
@@ -0,0 +1,60 @@
+From 2a38f26ed5695c3ad737de082b56a296240dd51a Mon Sep 17 00:00:00 2001
+From: Willem Toorop <willem@nlnetlabs.nl>
+Date: Thu, 19 Jan 2017 09:41:51 +0100
+Subject: bugfix #1209: make install ldns.pc file
+
+---
+ Changelog | 4 ++++
+ Makefile.in | 16 ++++++++++++++--
+ 2 files changed, 18 insertions(+), 2 deletions(-)
+
+diff --git a/Changelog b/Changelog
+index 0bd3658..efda95e 100644
+--- a/Changelog
++++ b/Changelog
+@@ -1,3 +1,7 @@
++1.7.1 ????-??-??
++ * bugfix #1209: make install ldns.pc file
++ Thanks Oleksandr Natalenko
++
+ 1.7.0 2016-12-20
+ * Fix lookup of relative names in ldns_resolver_search.
+ * bugfix #548: Double free for answers > 4096 in ldns_resolver_send_pkt
+diff --git a/Makefile.in b/Makefile.in
+index 04f683b..853777e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -308,9 +308,9 @@ clean-p5-dns-ldns: $(p5_dns_ldns_dir)/Makefile
+ test-p5-dns-ldns: $(p5_dns_ldns_dir)/Makefile
+ cd $(p5_dns_ldns_dir); $(MAKE) test
+
+-install: install-h install-lib @INSTALL_CONFIG@ install-manpages $(pyldns_inst) $(pyldnsx_inst) @INSTALL_P5_DNS_LDNS@ @INSTALL_DRILL@ @INSTALL_EXAMPLES@
++install: install-h install-lib install-pc @INSTALL_CONFIG@ install-manpages $(pyldns_inst) $(pyldnsx_inst) @INSTALL_P5_DNS_LDNS@ @INSTALL_DRILL@ @INSTALL_EXAMPLES@
+
+-uninstall: uninstall-manpages @UNINSTALL_CONFIG@ uninstall-h uninstall-lib $(pyldns_uninst) $(pyldnsx_uninst) @UNINSTALL_P5_DNS_LDNS@ @UNINSTALL_DRILL@ @UNINSTALL_EXAMPLES@
++uninstall: uninstall-manpages @UNINSTALL_CONFIG@ uninstall-h uninstall-lib uninstall-pc $(pyldns_uninst) $(pyldnsx_uninst) @UNINSTALL_P5_DNS_LDNS@ @UNINSTALL_DRILL@ @UNINSTALL_EXAMPLES@
+
+ destclean: uninstall
+
+@@ -355,6 +355,18 @@ uninstall-h:
+ test ! -d $(DESTDIR)$(includedir)/ldns || rmdir -p $(DESTDIR)$(includedir)/ldns || echo "ok, dir already gone"
+ exit 0
+
++packaging/libldns.pc: packaging/libldns.pc.in
++ ./config.status $@
++
++install-pc: packaging/libldns.pc
++ $(INSTALL) -m 644 packaging/libldns.pc $(DESTDIR)$(libdir)/pkgconfig/ldns.pc
++
++uninstall-pc:
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/pkgconfig/ldns.pc
++ test ! -d $(DESTDIR)$(libdir)/pkgconfig || rmdir -p $(DESTDIR)$(libdir)/pkgconfig || echo "ok, dir already gone"
++ test ! -d $(DESTDIR)$(libdir) || rmdir -p $(DESTDIR)$(libdir) || echo "ok, dir already gone"
++
++
+ install-lib: lib
+ $(INSTALL) -m 755 -d $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install cp libldns.la $(DESTDIR)$(libdir)
+--
+cgit v0.11.2
+