summaryrefslogtreecommitdiffstats
path: root/abs/core/libfetch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libfetch/Makefile')
-rw-r--r--abs/core/libfetch/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/abs/core/libfetch/Makefile b/abs/core/libfetch/Makefile
index 15df96e..53bcee9 100644
--- a/abs/core/libfetch/Makefile
+++ b/abs/core/libfetch/Makefile
@@ -5,7 +5,7 @@ FETCH_WITH_INET6 = true
FETCH_WITH_OPENSSL = true
WARNINGS = -Wall -Wstrict-prototypes -Wsign-compare -Wchar-subscripts \
- -Wpointer-arith -Wcast-align -Wsign-compare
+ -Wpointer-arith -Wcast-align
CFLAGS = -O2 -pipe -I. -fPIC $(WARNINGS) \
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES
@@ -42,18 +42,17 @@ E = @/bin/echo
Q = @
all: libfetch.so libfetch.a
- $(E) " built with: " $(CFLAGS)
.PHONY: all
%.o: %.c $(INCS) $(GEN)
$(E) " compile " $@
$(Q) $(CC) $(CFLAGS) -c $<
-ftperr.h: ftp.errors
+ftperr.h: ftp.errors Makefile errlist.sh
$(E) " generate " $@
$(Q) ./errlist.sh ftp_errlist FTP ftp.errors > $@
-httperr.h: http.errors
+httperr.h: http.errors Makefile errlist.sh
$(E) " generate " $@
$(Q) ./errlist.sh http_errlist HTTP http.errors > $@
@@ -61,12 +60,14 @@ libfetch.so: $(GEN) $(INCS) $(OBJS)
$(E) " build " $@
$(Q) rm -f $@
$(Q) $(LD) $(LDFLAGS) *.o -shared -o $@
+ $(E) " built with: " $(CFLAGS)
libfetch.a: $(GEN) $(INCS) $(OBJS)
$(E) " build " $@
$(Q) rm -f $@
$(Q) $(AR) rcs $@ *.o
$(Q) $(RANLIB) $@
+ $(E) " built with: " $(CFLAGS)
clean:
$(E) " clean "