summaryrefslogtreecommitdiffstats
path: root/abs/core/libidn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libidn/PKGBUILD')
-rw-r--r--abs/core/libidn/PKGBUILD42
1 files changed, 28 insertions, 14 deletions
diff --git a/abs/core/libidn/PKGBUILD b/abs/core/libidn/PKGBUILD
index 42aaa09..c911e6b 100644
--- a/abs/core/libidn/PKGBUILD
+++ b/abs/core/libidn/PKGBUILD
@@ -1,29 +1,43 @@
-# $Id: PKGBUILD 162005 2012-06-18 08:51:29Z ronald $
+# $Id$
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Jan de Groot <jgc.archlinux.org>
# Contributor: Eric Johnson <eric.archlinux.org>
pkgname=libidn
-pkgver=1.25
-pkgrel=1
+pkgver=1.33
+pkgrel=2
pkgdesc="Implementation of the Stringprep, Punycode and IDNA specifications"
-url="http://www.gnu.org/software/libidn/"
-arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/libidn/"
+arch=('x86_64')
license=('GPL3' 'LGPL')
-depends=('glibc' 'texinfo')
-makedepends=('pkgconfig')
-options=('!libtool')
-source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-install=libidn.install
-sha1sums=('92e64fd5a6428bda6ade2c3cde475b76455cd7dd')
-
+depends=('glibc')
+source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig}
+ gcc7_buildfix.diff)
+sha256sums=('44a7aab635bb721ceef6beecc4d49dfd19478325e1b47f3196f7d2acc4930e19'
+ 'SKIP'
+ '1b539ba3916fe8982d596f4de9a65138ae9a35a042e1673328a092a478b7fb33')
+validpgpkeys=('9AA9BDB11BB1B99A21285A330664A76954265E8C') # "Simon Josefsson <simon@josefsson.org>"
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ # fix build with gcc7
+ patch -Np1 -i ../gcc7_buildfix.diff
+}
+
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
}
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
+ # doc html installation - gtk-doc isn't supported anymore - FS#55151
+ mkdir -p ${pkgdir}/usr/share/gtk-doc/html/${pkgname}
+ cp -r -v doc/reference/html/* ${pkgdir}/usr/share/gtk-doc/html/${pkgname}
}