summaryrefslogtreecommitdiffstats
path: root/abs/core/libnghttp2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libnghttp2/PKGBUILD')
-rw-r--r--abs/core/libnghttp2/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core/libnghttp2/PKGBUILD b/abs/core/libnghttp2/PKGBUILD
new file mode 100644
index 0000000..592082b
--- /dev/null
+++ b/abs/core/libnghttp2/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 289632 2017-02-27 17:36:38Z anatolik $
+# Maintainer: Anatol Pomozov
+# Contributor: Zhuoyun Wei <wzyboy@wzyboy.org>
+
+pkgname=libnghttp2
+pkgver=1.30.0
+pkgrel=1
+pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
+arch=(x86_64)
+url='https://nghttp2.org/'
+license=(MIT)
+depends=(glibc)
+conflicts=('nghttp2<1.20.0-2')
+source=(https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz)
+sha256sums=('089afb4c22a53f72384b71ea06194be255a8a73b50b1412589105d0e683c52ac')
+
+build() {
+ cd nghttp2-$pkgver
+
+ autoreconf -i
+ ./configure \
+ --prefix=/usr \
+ --disable-examples \
+ --disable-python-bindings \
+ --enable-lib-only
+ make
+}
+
+check() {
+ cd nghttp2-$pkgver
+ make check
+}
+
+package() {
+ cd nghttp2-$pkgver/lib
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/libnghttp2/COPYING"
+}