summaryrefslogtreecommitdiffstats
path: root/abs/core/libstatgrab/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libstatgrab/PKGBUILD')
-rw-r--r--abs/core/libstatgrab/PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/abs/core/libstatgrab/PKGBUILD b/abs/core/libstatgrab/PKGBUILD
index a531c26..14ca612 100644
--- a/abs/core/libstatgrab/PKGBUILD
+++ b/abs/core/libstatgrab/PKGBUILD
@@ -1,28 +1,30 @@
-# $Id: PKGBUILD 22416 2010-07-21 18:45:21Z jlichtblau $
+# $Id$
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Hugo Ideler <hugoideler@dse.nl>
pkgname=libstatgrab
-pkgver=0.16
+pkgver=0.91
pkgrel=2
pkgdesc="A library that provides cross platform access to statistics about the system on which it's run"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.i-scream.org/libstatgrab"
license=('LGPL' 'GPL')
depends=('ncurses' 'perl')
-options=('!libtool' '!makeflags')
+options=('!makeflags')
changelog=$pkgname.changelog
-source=(http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/$pkgname-$pkgver.tar.gz)
-md5sums=('77582438274679a9641d043ddcccdd4e')
+source=(http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('03e9328e4857c2c9dcc1b0347724ae4cd741a72ee11acc991784e8ef45b7f1ab')
build() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --prefix=/usr
- make || return 1
+ make
}
+
package() {
- cd ${srcdir}/$pkgname-$pkgver
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
}