summaryrefslogtreecommitdiffstats
path: root/abs/core/libvisual-plugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libvisual-plugins/PKGBUILD')
-rw-r--r--abs/core/libvisual-plugins/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/abs/core/libvisual-plugins/PKGBUILD b/abs/core/libvisual-plugins/PKGBUILD
new file mode 100644
index 0000000..cced714
--- /dev/null
+++ b/abs/core/libvisual-plugins/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=libvisual-plugins
+pkgver=0.4.0
+pkgrel=6
+pkgdesc="plugins for libvisual"
+arch=("i686" "x86_64")
+license=('GPL')
+url="http://www.localhost.nl/~synap/libvisual/"
+depends=('libvisual>=0.4.0' 'gtk2' 'mesa' 'alsa-lib' 'esd' 'jack-audio-connection-kit')
+makedepends=(pkgconfig bison)
+install=libvisual-plugins.install
+source=("http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.gz"
+ '01_disable-gforce-dfsg.patch'
+ '02_64-bit_JESS_fix.patch'
+ '03_build_against_gl_fixes.patch'
+ '04_lv_analyzer_build_fix.patch'
+ '05_fix_po.patch'
+ '60_no-const-vispluginfo-in-nastyfft.patch'
+ '90_autoreconf.patch')
+md5sums=('4330e9287f9d6fae02f482f428a1e77b'
+ '600969a691372c8894c90765de84f732'
+ 'f9cfb607bfcbfef60830fae4e7dc6963'
+ '116701408747dbb87dc134434478ebe2'
+ '01678a8f1584c76a44e59d81003a1109'
+ '6189b7427c4e11c8b8d6c6266d6a1629'
+ '7012518727cb072a7e90a826a5577cc6'
+ '4aa3ffc17dcb4d25129f483b1842fac9')
+options=(!libtool)
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+# patch -p1 < ../01_disable-gforce-dfsg.patch
+# patch -p1 < ../02_64-bit_JESS_fix.patch
+# patch -p1 < ../03_build_against_gl_fixes.patch
+# patch -p1 < ../04_lv_analyzer_build_fix.patch
+# patch -p1 < ../05_fix_po.patch
+# patch -p1 < ../60_no-const-vispluginfo-in-nastyfft.patch
+# patch -p1 < ../90_autoreconf.patch
+ ./configure --prefix=/usr --enable-alsa --disable-gstreamer-plugin \
+ --disable-gdkpixbuf-plugin --disable-nastyfft --disable-madspin --disable-flower --disable-bumpscope --disable-gltest
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}