summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libxcb/PKGBUILD')
-rw-r--r--abs/core/libxcb/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index 126d0a8..92ad925 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -4,22 +4,25 @@
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=libxcb
-pkgver=1.11
+pkgver=1.12
pkgrel=1
pkgdesc="X11 client-side library"
arch=('i686' 'x86_64')
-url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.11' 'libxdmcp' 'libxau')
+url="https://xcb.freedesktop.org/"
+depends=('xcb-proto>=1.12' 'libxdmcp' 'libxau')
makedepends=('libxslt' 'python2' 'xorg-util-macros')
license=('custom')
source=($url/dist/$pkgname-$pkgver.tar.bz2
- libxcb-1.1-no-pthread-stubs.patch)
-sha256sums=('03635d70045b9ede90778e67516135828a57de87ac508f987024f43c03620ff7'
- '3923bcb1930b851012968435909597d8d5251c72153511cb2982636c97100cc3')
+ libxcb-1.1-no-pthread-stubs.patch
+ python-35x-fixes.patch)
+sha256sums=('4adfb1b7c67e99bc9c2ccb110b2f175686576d2f792c8a71b9c8b19014057b5b'
+ '37debaf892235a516a50a4975e6229538d3b4696b4571a8dea05eed774004aff'
+ 'e66140ac2270b47e940db82975e2d28d3536ca1bd0eae63bce3b900ed81fa517')
prepare() {
cd "$pkgname-$pkgver"
patch -Np1 -i ../libxcb-1.1-no-pthread-stubs.patch
+# patch -Np1 -i ../python-35x-fixes.patch
autoreconf -vfi
}
@@ -29,7 +32,7 @@ build() {
--enable-xinput \
--enable-xkb \
--disable-static
- make
+ make -j1
}
check() {