summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-theme/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/linhes-theme/PKGBUILD')
-rw-r--r--abs/core/linhes-theme/PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 7f58de5..f261ac0 100644
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,18 +1,19 @@
pkgname=linhes-theme
pkgver=8.1
-pkgrel=2
+pkgrel=3
pkgdesc="Default LinHES MythTV theme"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linhes.org/"
patches=('readme.txt.patch' 'osd.xml.patch' 'base.xml.patch'
- 'menu-ui.xml.patch')
+ 'menu-ui.xml.patch' 'schedule-ui.xml.patch')
#The LinHES theme is based on TintedGlass by Harley Peters
source=("git://github.com/MythTV-Themes/TintedGlass.git"
- `echo ${patches[@]:0}` 'themeinfo.xml'
- 'background.png' 'qt-background.png' 'tux_thoughts.png')
+ `echo ${patches[@]:0}` 'themeinfo.xml' 'install-ui.xml'
+ 'background.png' 'qt-background.png' 'tux_thoughts.png'
+ 'progdetails_page1.html' 'progdetails_page2.html')
package() {
THEMEROOT=usr/share/mythtv/themes
@@ -32,13 +33,18 @@ package() {
cd $startdir
msg "--------------------------done applying patches-------------------------"
- msg "Copy themeinfo.xml and adding backgrounds and images for LinHES"
- rsync -pL $srcdir/themeinfo.xml $pkgdir/$THEMEROOT/LinHES/
+ msg "Copy *.xml and adding backgrounds and images for LinHES"
+ rsync -pL $srcdir/*.xml $pkgdir/$THEMEROOT/LinHES/
rm -r $pkgdir/$THEMEROOT/LinHES/images/backgrounds/*
rsync -pL $srcdir/*background.png $pkgdir/$THEMEROOT/LinHES/images/backgrounds/
+
#tux_thoughts.png is the thought bubble for the menu descriptions
rsync -pL $srcdir/tux_thoughts.png $pkgdir/$THEMEROOT/LinHES/images/
+ #copy in progdetails
+ mkdir -p $pkgdir/$THEMEROOT/LinHES/htmls
+ rsync -pL $srcdir/progdetails_page*.html $pkgdir/$THEMEROOT/LinHES/htmls/
+
msg "Modifying yellows and blue to LinHES yellow and blue"
#yellow
grep -lr '#d9d900' $pkgdir/$THEMEROOT/LinHES/ | xargs sed -i "s/\#d9d900/\#ebb81c/g"
@@ -47,13 +53,16 @@ package() {
#blue
grep -lr '#3a9ade' $pkgdir/$THEMEROOT/LinHES/ | xargs sed -i "s/\#3a9ade/\#0072bc/g"
}
-
md5sums=('SKIP'
'9c2fc68864cbedb6e449056972b457aa'
'15b4462932b7be0e56b2e69e0214823a'
'2fb0990e8fef2c70e9bd8cfb36689b2b'
'83b03852c6f46bc791bfa6e8c894ca01'
+ '45d2f265218ab951eefe76adff38c54b'
'7d7bc458a8f4af408700609f3e1f412e'
+ 'eb94abdc196051db708e4a9eb938923a'
'cbe5f663ebb5d51abe811f81dafec303'
'12d26a786fde397348653128a6d7676a'
- '2bd09b8049aaf5ba21db5baf3a0ce077')
+ '2bd09b8049aaf5ba21db5baf3a0ce077'
+ 'cc2b5da9ad34704d773f3235bf686835'
+ 'be7853c2c9598481368c10f0eb5ad43f')