summaryrefslogtreecommitdiffstats
path: root/abs/core/linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/linux/PKGBUILD')
-rw-r--r--abs/core/linux/PKGBUILD42
1 files changed, 21 insertions, 21 deletions
diff --git a/abs/core/linux/PKGBUILD b/abs/core/linux/PKGBUILD
index 65d831a..1e30ad9 100644
--- a/abs/core/linux/PKGBUILD
+++ b/abs/core/linux/PKGBUILD
@@ -3,28 +3,28 @@
pkgbase=linux
#pkgbase=linux-custom
-_srcname=linux-4.4
-pkgver=4.4.58
+_srcname=linux-4.9
+pkgver=4.9.20
pkgrel=1
arch=('i686' 'x86_64')
url="https://www.kernel.org/"
license=('GPL2')
-makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
+makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
# the main kernel config files
'config' 'config.x86_64'
# pacman hook for initramfs regeneration
- '99-linux.hook'
+ '90-linux.hook'
# standard config files for mkinitcpio ramdisk
linux.preset
- change-default-console-loglevel.patch
- 0001-sdhci-revert.patch)
+ change-default-console-loglevel.patch)
# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds <torvalds@linux-foundation.org>
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman (Linux kernel stable release signing key) <greg@kroah.com>
)
+
_kernelname=${pkgbase#linux}
prepare() {
@@ -36,11 +36,6 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
- # revert http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9faac7b95ea4f9e83b7a914084cc81ef1632fd91
- # fixes #47778 sdhci broken on some boards
- # https://bugzilla.kernel.org/show_bug.cgi?id=106541
- patch -Rp1 -i "${srcdir}/0001-sdhci-revert.patch"
-
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -123,8 +118,8 @@ _package() {
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
# install pacman hook for initramfs regeneration
- sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
- install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
+ sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/90-linux.hook" |
+ install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/90-${pkgbase}.hook"
# remove build and source links
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
@@ -166,7 +161,7 @@ _package-headers() {
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/include"
for i in acpi asm-generic config crypto drm generated keys linux math-emu \
- media net pcmcia scsi sound trace uapi video xen; do
+ media net pcmcia scsi soc sound trace uapi video xen; do
cp -a include/${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/include/"
done
@@ -246,6 +241,12 @@ _package-headers() {
cp ${i} "${pkgdir}/usr/lib/modules/${_kernver}/build/${i}"
done
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ if [ -f tools/objtool/objtool ]; then
+ mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool"
+ cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/
+ fi
+
chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
@@ -291,13 +292,12 @@ for _p in ${pkgname[@]}; do
_package${_p#${pkgbase}}
}"
done
-md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
+md5sums=('0a68ef3615c64bd5ee54a3320e46667d'
'SKIP'
- '152561e51e76089c5b045f8c0257f9d5'
+ '1d336b33f01320e3bdbdc2d9b52aadbd'
'SKIP'
- 'be50f82adaeb685d41eb55acd1b09134'
- 'd254ffa0b91d459529ec23a1cdeceb35'
+ '2d73fc24ab59870bebde25e591e1bfb8'
+ 'eca4246ff4ef81f714e0d909b5293b64'
'90cd68710e3064d9b65f5549570f7821'
- 'eb14dcfd80c00852ef81ded6e826826a'
- 'df7fceae6ee5d7e7be7b60ecd7f6bb35'
- 'e1093d9bc718f362344ab56b85d4fb76')
+ '232b52576a62c7a333e9fe7a1e1ca359'
+ 'df7fceae6ee5d7e7be7b60ecd7f6bb35')