summaryrefslogtreecommitdiffstats
path: root/abs/core/lirc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/lirc/PKGBUILD')
-rw-r--r--abs/core/lirc/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/abs/core/lirc/PKGBUILD b/abs/core/lirc/PKGBUILD
index 666865f..5a9d5e5 100644
--- a/abs/core/lirc/PKGBUILD
+++ b/abs/core/lirc/PKGBUILD
@@ -1,17 +1,17 @@
-# $Id: PKGBUILD 202757 2013-12-26 13:05:51Z thomas $
+# $Id$
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgbase=lirc
pkgname=('lirc' 'lirc-utils')
pkgver=0.9.0
-pkgrel=67
+pkgrel=70
epoch=1
-_extramodules=extramodules-3.12-ARCH
+_extramodules=extramodules-3.13-ARCH
arch=('i686' 'x86_64')
url="http://www.lirc.org/"
license=('GPL')
### NOTICE don't forget to bump version in depends in package_lirc
-makedepends=('help2man' 'linux>=3.12' 'linux<3.13' 'linux-headers>=3.12' 'linux-headers<3.13' 'alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'python2' 'iguanair')
+makedepends=('help2man' 'linux>=3.13' 'linux<3.14' 'linux-headers>=3.13' 'linux-headers<3.14' 'alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'python2' 'iguanair')
options=('!makeflags' '!strip')
source=(http://prdownloads.sourceforge.net/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2
lirc_wpc8769l.patch
@@ -67,7 +67,7 @@ build() {
cd "${srcdir}/lirc-${pkgver}"
PYTHON=python2 ./configure --enable-sandboxed --prefix=/usr \
- --with-driver=all --with-kerneldir=/usr/src/linux-${_kernver}/ \
+ --with-driver=all --with-kerneldir=/usr/lib/modules/${_kernver}/build \
--with-moduledir=/usr/lib/modules/${_kernver}/kernel/drivers/misc \
--sbindir=/usr/bin --with-transmitter
@@ -82,7 +82,7 @@ build() {
package_lirc() {
pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
- depends=('lirc-utils' 'linux>=3.12' 'linux<3.13' 'iguanair')
+ depends=('lirc-utils' 'linux>=3.13' 'linux<3.14')
replaces=('lirc+pctv')
install=lirc.install
@@ -97,7 +97,7 @@ package_lirc() {
package_lirc-utils() {
pkgdesc="Linux Infrared Remote Control utils"
- depends=('alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'iguanair')
+ depends=('alsa-lib' 'libx11' 'libftdi-compat' 'libirman')
optdepends=('python2: pronto2lirc utility')
options=('strip')
install=lirc-utils.install