summaryrefslogtreecommitdiffstats
path: root/abs/core/lockdev/build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/lockdev/build.patch')
-rw-r--r--abs/core/lockdev/build.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/lockdev/build.patch b/abs/core/lockdev/build.patch
new file mode 100644
index 0000000..f1053d0
--- /dev/null
+++ b/abs/core/lockdev/build.patch
@@ -0,0 +1,30 @@
+commit 0dd47123655c52d68185f06b9da8fb0e1b925400
+Author: Ludwig Nussel <ludwig.nussel@suse.de>
+Date: Tue Feb 9 14:56:23 2010 +0100
+
+ RedHat patch 2
+
+ - change library file name
+ - install devel symlink
+
+diff --git a/Makefile b/Makefile
+index b7b4d1f..3b351dd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@ VER = $(shell expr `pwd` : '.*-\([0-9.]*\)')
+ MVER = ${shell expr `pwd` : '.*-\([0-9]*\).[0-9]*'}
+
+ static = ${libname}.a
+-shared = ${libname}.${VER}.so
++shared = ${libname}.so.${VER}
+ soname = ${libname}.so.${MVER}
+
+ # overwritten by caller (e.g.: debian/rules)
+@@ -76,6 +76,7 @@ install_doc: docs/lockdev.3
+ install_run: ${shared}
+ install -m755 -d ${libdir}
+ install -m644 ${shared} ${libdir}
++ ln -s ${shared} ${libdir}/liblockdev.so
+
+ .PHONY: clean distclean perl-clean mostyclean
+ perl-clean: clean