summaryrefslogtreecommitdiffstats
path: root/abs/core/miscsplashutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/miscsplashutils/PKGBUILD')
-rw-r--r--abs/core/miscsplashutils/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/miscsplashutils/PKGBUILD b/abs/core/miscsplashutils/PKGBUILD
new file mode 100644
index 0000000..e0b85c8
--- /dev/null
+++ b/abs/core/miscsplashutils/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+pkgname=miscsplashutils
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="Miscellaneous framebuffer utilities including fbres and fbtruetype"
+arch=(i686 x86_64)
+url="http://dev.gentoo.org/~spock/projects/gensplash/"
+license=('GPL')
+depends=('freetype2')
+conflicts=('bootsplash')
+install=miscsplashutils.install
+source=(http://dev.gentoo.org/~spock/projects/gensplash/current/$pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make || return 1
+ make DESTDIR=$startdir/pkg/ install
+
+ install -d $startdir/pkg/lib/splash/bin
+ touch $startdir/pkg/lib/splash/bin/wc
+
+ # install luxisri.ttf to avoid an x-server dependency
+ install -D -m644 fbtruetype/luxisri.ttf $startdir/pkg/etc/splash/luxisri.ttf
+}
+md5sums=('0a9505c5c5ed169e6158d2c1b06ff40b')