summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio-busybox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mkinitcpio-busybox/PKGBUILD')
-rw-r--r--abs/core/mkinitcpio-busybox/PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/abs/core/mkinitcpio-busybox/PKGBUILD b/abs/core/mkinitcpio-busybox/PKGBUILD
index f85beb6..023f630 100644
--- a/abs/core/mkinitcpio-busybox/PKGBUILD
+++ b/abs/core/mkinitcpio-busybox/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 167188 2012-09-27 01:16:40Z dreisner $
+# $Id$
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mkinitcpio-busybox
-pkgver=1.20.2
-pkgrel=1
+pkgver=1.21.1
+pkgrel=2
pkgdesc="base initramfs tools"
arch=('i686' 'x86_64')
url="http://www.busybox.net/"
@@ -14,21 +14,22 @@ options=('!buildflags')
source=("http://busybox.net/downloads/busybox-$pkgver.tar.bz2"
'glibc-2.16.patch'
'config')
-sha256sums=('eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882'
+sha256sums=('cd5be0912ec856110ae12c76c3ec9cd5cba1df45b5a9da2b095b8284d1481303'
'fb5b6e2a0de4db5401322e5c2474ad8ce6a58615dad45b7109cfe045baf2c88d'
- 'd8064ed6ec21868e4afe057445e2d852b353abd595132cb1ca3ba345988772f0')
+ '240c9ab805fbf5eb3347b2a42f62d840f160c4999d0f172b28ba50dadad09ada')
-build() {
- cd "$srcdir/busybox-$pkgver"
+prepare() {
+ cd "busybox-$pkgver"
- local safeflags="${CARCH/_/-} -mtune=generic -Os -pipe -fno-strict-aliasing"
+ local safeflags="-march=${CARCH/_/-} -mtune=generic -Os -pipe -fno-strict-aliasing"
- sed 's|^\(CONFIG_EXTRA_CFLAGS\)=.*|\1="-march='"$safeflags"'"|' \
- "$srcdir/config" > .config
+ sed 's|^\(CONFIG_EXTRA_CFLAGS\)=.*|\1="'"$safeflags"'"|' "$srcdir/config" >.config
- patch -Np1 < "$srcdir/glibc-2.16.patch"
+ patch -Np1 <"$srcdir/glibc-2.16.patch"
+}
- make
+build() {
+ make -C "busybox-$pkgver"
}
package() {