summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio-busybox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mkinitcpio-busybox/PKGBUILD')
-rw-r--r--abs/core/mkinitcpio-busybox/PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/abs/core/mkinitcpio-busybox/PKGBUILD b/abs/core/mkinitcpio-busybox/PKGBUILD
index 3d2beaf..6f0de2d 100644
--- a/abs/core/mkinitcpio-busybox/PKGBUILD
+++ b/abs/core/mkinitcpio-busybox/PKGBUILD
@@ -1,7 +1,7 @@
-# $Id: PKGBUILD 84550 2010-06-30 21:45:04Z thomas $
+# $Id: PKGBUILD 90030 2010-09-06 17:22:38Z thomas $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mkinitcpio-busybox
-pkgver=1.16.2
+pkgver=1.17.2
pkgrel=1
pkgdesc="base initramfs tools"
arch=('i686' 'x86_64')
@@ -9,19 +9,13 @@ url="http://www.busybox.net/"
license=('GPL')
depends=('glibc')
source=(http://busybox.net/downloads/busybox-${pkgver}.tar.bz2
- config
- loadfont-setfont-optional-psf2-font-support.patch)
-sha256sums=('3bf1b1a41294d25335abdd10c65cffdb01c36337ca011f1b38c6ad89590115ba'
- 'd629e936941c854e7aa5e1b564d74bde3a1d328f1e0dd30c86a958d2724685ce'
- '624d21345cd869c174a3ae1b9cfe23a461ce8b463c7ac4c052726430890c4eb1')
+ config)
+sha256sums=('7a4c9d59098734c86c3bfef421719c3239ca213bba071e284e2352ff4a01cac6'
+ 'd2131815c28b987b0f7bf9065e7cf567c656438fbe0d44b685dc7dba387a1ca9')
build() {
cd "${srcdir}/busybox-${pkgver}"
- # Backport http://git.busybox.net/busybox/commit/?id=8ce1dc03c1b2b61e51527b987579c09c991cc4b2
- # to busybox 1.16 to fix https://bugs.archlinux.org/task/19109
- patch -p1 -i ../loadfont-setfont-optional-psf2-font-support.patch || return 1
-
unset CFLAGS CXXFLAGS
if [ ${CARCH} = "x86_64" ]; then
sed 's|^CONFIG_EXTRA_CFLAGS=.*|CONFIG_EXTRA_CFLAGS="-march=x86-64 -mtune=generic -Os -pipe -fno-strict-aliasing"|' "${srcdir}/config" > .config
@@ -32,6 +26,7 @@ build() {
}
package() {
+ cd "${srcdir}/busybox-${pkgver}"
install -D -m755 "${srcdir}/busybox-${pkgver}"/busybox "${pkgdir}/lib/initcpio/busybox"
}
# vim:set ts=2 sw=2 et: