summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio-busybox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mkinitcpio-busybox/PKGBUILD')
-rw-r--r--abs/core/mkinitcpio-busybox/PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/abs/core/mkinitcpio-busybox/PKGBUILD b/abs/core/mkinitcpio-busybox/PKGBUILD
index 55071e0..f85beb6 100644
--- a/abs/core/mkinitcpio-busybox/PKGBUILD
+++ b/abs/core/mkinitcpio-busybox/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 160678 2012-06-03 16:32:18Z dreisner $
+# $Id: PKGBUILD 167188 2012-09-27 01:16:40Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mkinitcpio-busybox
-pkgver=1.20.1
+pkgver=1.20.2
pkgrel=1
pkgdesc="base initramfs tools"
arch=('i686' 'x86_64')
@@ -12,16 +12,22 @@ license=('GPL')
depends=('glibc')
options=('!buildflags')
source=("http://busybox.net/downloads/busybox-$pkgver.tar.bz2"
- 'config' 'sys_resource.patch')
+ 'glibc-2.16.patch'
+ 'config')
+sha256sums=('eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882'
+ 'fb5b6e2a0de4db5401322e5c2474ad8ce6a58615dad45b7109cfe045baf2c88d'
+ 'd8064ed6ec21868e4afe057445e2d852b353abd595132cb1ca3ba345988772f0')
build() {
cd "$srcdir/busybox-$pkgver"
- patch -Np1 < $srcdir/sys_resource.patch
+
local safeflags="${CARCH/_/-} -mtune=generic -Os -pipe -fno-strict-aliasing"
sed 's|^\(CONFIG_EXTRA_CFLAGS\)=.*|\1="-march='"$safeflags"'"|' \
"$srcdir/config" > .config
+ patch -Np1 < "$srcdir/glibc-2.16.patch"
+
make
}
@@ -30,6 +36,3 @@ package() {
}
# vim:set ts=2 sw=2 et:
-md5sums=('af2fededb6dca804544c05684636e574'
- 'dd4c0fefe9bb9e65945a5b5525543fd7'
- '47e725861776dbaad351e021c9a4df5a')