summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mkinitcpio/PKGBUILD')
-rw-r--r--abs/core/mkinitcpio/PKGBUILD42
1 files changed, 26 insertions, 16 deletions
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index 0631650..282b2bb 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -1,29 +1,39 @@
+# $Id: PKGBUILD 161860 2012-06-15 22:35:26Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
-
pkgname=mkinitcpio
-pkgver=0.7.2
-pkgrel=11
+pkgver=0.9.2
+pkgrel=2
pkgdesc="Modular initramfs image creation utility"
-arch=(any)
+arch=('any')
url="http://www.archlinux.org/"
license=('GPL')
-depends=('mkinitcpio-busybox>=1.16.1-2' 'mkinitcpio-nfs-utils=>0.2' 'module-init-tools' 'util-linux>=2.19' 'libarchive' 'coreutils'
- 'bash' 'findutils' 'sed' 'grep' 'filesystem>=2009.01-2' 'udev>=171-2' 'file' 'gzip'
- 'which')
+depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod>=3' 'util-linux>=2.21' 'libarchive' 'coreutils'
+ 'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd-tools')
optdepends=('xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
-replaces=('mkinitrd' 'mkinitramfs' 'klibc' 'klibc-extras' 'klibc-kbd'
- 'klibc-module-init-tools' 'klibc-udev')
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz mkinitcpio.conf.patch)
-backup=(etc/mkinitcpio.conf)
+backup=('etc/mkinitcpio.conf')
+source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
+ 0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
+ 0002-shutdown-don-t-alert-udev-on-disable-VGs.patch)
+install=mkinitcpio.install
+sha256sums=('1c388ab1df4ecdf6204602c66220a79adc2c564956fdf68deb7dde9bab331c28'
+ '5e5f83a2f9805ce1b09602f31fd4aca93fa7085a40c74bc559cf25c29506b057'
+ 'e32a7955b94e378698268f9cfd07fb0285a4efbdc4b26ea40714e7f1a54705a1')
package() {
- cd $srcdir/${pkgname}-${pkgver}
- patch -p0 < $srcdir/mkinitcpio.conf.patch
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 <"$srcdir"/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
+ patch -Np1 <"$srcdir"/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
+
+ make DESTDIR="$pkgdir" install
+
+ # compat symlink
+ install -dm755 "$pkgdir/sbin"
+ ln -s /usr/bin/mkinitcpio "$pkgdir/sbin/mkinitcpio"
}
-md5sums=('e11670a7d4802b2ef20cab4b3815168a'
- '36da3320c907bf3b41b74fc824cbd1d8')
+